Showing results for 
Search instead for 
Did you mean: 

SUPEE-8788 fails on SWF files


SUPEE-8788 fails on SWF files

This is on Magento CE with fully applied previous patches.

When running the patch through SSH, it fails with hunk ignored on those 3 SWF files.

Those files have never been modified. Anyway, tried to replace them with the original copies from ver., but still no luck.

Has anyone got the same problem?


Accepted Solutions

Re: SUPEE-8788 fails on SWF files

I actually got the patch to install successfully by zipping/unzipping the .sh file.

This sounds unusual, but the process might encode/decode the hex contents on the file correctly.


So, firstly, I zipped .sh file with 7zip to .zip extension. Then I uploaded it to the server with CPanel, and unzipped it with CPanel Extract. Lastly, I went to the terminal with PuTTy and ran it. The patch was successfully applied.

I then logged in to the back end system and cleared all caches.


The new image uploader is there but... it doesn't work.

So, if anyone still need to upload some stuff, don't apply this patch yet.

The continuation of this problem is going to this page:


Can anyone report if this new image uploader work on you?


View solution in original post


Re: SUPEE-8788 fails on SWF files

I've had the same exact problem. I'm running Magento CE I also tried replacing the SWF files with originals from a fresh download of, but it didn't work for me either. 


If I don't find a solution to the SWF problem, I'm considering updating to 1.9.3. This is not ideal because core updates are time consuming affairs for me.


If I find a solution, I'll share it on this discussion.

Re: SUPEE-8788 fails on SWF files

Yep, same issue for me, Version CE, all previous patches successfully applied - although I do remember some similar problems with a previous patch which needed the default .htaccess etc restoring before applying.


Any suggestions appreciated.

Re: SUPEE-8788 fails on SWF files

A dirty solution might be to remove the swf files from the patch. Then download the 1.9.3 release and get the swf files from there. Use the smaller patch and upload the swf files manually.


I have not tested this yet,

Re: SUPEE-8788 fails on SWF files

Hmm..dirty Smiley Wink might give it a try if a clean option isn't forthcoming. In addition, I also have the following failure:


patching file app/code/core/Mage/Adminhtml/controllers/DashboardController.php
Hunk #1 FAILED at 91.
1 out of 1 hunk FAILED -- saving rejects to file app/code/core/Mage/Adminhtml/controllers/DashboardController.php.rej


Have read some comments that php v.5.6 or higher is required or the Magento backend will be inaccessible after applying 8788, we're on 5.4.4 at the moment, possibly related?


I also had a failure related to the downloader, presumably because I renamed the downloader folder as a quick and easy way to secure it...

Re: SUPEE-8788 fails on SWF files

For anyone having problems with the .swf updates of the patch, I simply removed lines 5951-9818 from the patch and manually removed the .swf files from /skin/adminhtml/default/default/media - since that's all the patch was doing anyway.

Re: SUPEE-8788 fails on SWF files

Thanks for the info Liam. What did you use to edit the .sh file? Opening in notepad++ I don't have a line 9818, numbering only goes up to 9059. There's also been some comments about text editors breaking the binary in the patch file.




Re: SUPEE-8788 fails on SWF files

Same issue here. Magento with all previous patches installed:


1 out of 1 hunk ignored -- saving rejects to file skin/adminhtml/default/default/media/uploaderSingle.swf.rej

Re: SUPEE-8788 fails on SWF files

Removing the lines worked in my case (running on

use 'sed' on cli for removing the lines, example:

sed -i '5951,9818 d'


See also:

Re: SUPEE-8788 fails on SWF files

Removing the lines as suggested by Liam did the trick for me on I manually removed the 3 .swf files and the patch succesfully applied. I edited the file with notepad++.