cancel
Showing results for 
Search instead for 
Did you mean: 

Security update to 1.9.2.3 and Meanbee Royal Mail

Security update to 1.9.2.3 and Meanbee Royal Mail

Hi,

 

After a security upgrade to 1.9.2.3, the Meanbee Royal Mail extension is not working. This is on PHP 5.3. All other shipping options are disabled.


Going through the one-page checkout, you get as far as shipping, but just get "Sorry, no quotes are available for this order at this time."


The Meanbee Royal Mail config options in the backend display OK. It's just in the frontend that the extension seems to do nothing.

Has anyone else come across this?

thanks,

-- Tim.

 

10 REPLIES

Re: Security update to 1.9.2.3 and Meanbee Royal Mail

I have the exactly the same situation. I re-installed Meanbee and that failed due to a missing require ...

 

/var/www/html/shop/lib/Meanbee/RoyalmailPHPLibrary/Src/CalculateMethod.php

 

so I copied the contents of 

 

/var/www/html/shop/lib/Meanbee/RoyalmailPHPLibrary/src/

 

to

/var/www/html/shop/lib/Meanbee/RoyalmailPHPLibrary/Src/

 

and that got me past that error, but still no joy with getting a shipping method.

Re: Security update to 1.9.2.3 and Meanbee Royal Mail

Hi,  

Apologies for the difficulty with the extension, however we are compatible with the newest version of Magento, the security patch, and PHP 5.3 so that shouldn't be causing any problems.

 

Can you please ensure that you are on the latest version of the extension available on Magento connect, 2.7.4, as well as making sure that you have selected the appropriate countries and shipping methods in the admin area of the extension? You might need to uninstall the previous version and then install the new version for it to work correctly, as well as clearing cache after the installation.

 

Regarding the issue with the src folder, this is a problem caused by case sensitivity and the Magento autoloader auto-capitalising paths. It was fixed in a recent update to the extension, and should be solved by updating the extension. 

 

Thanks, 

Meanbee Magento Extension Support

Re: Security update to 1.9.2.3 and Meanbee Royal Mail

Hi,

I'm also having this issue, have removed the extension and installed the latest Github version, still not showing a postage quote.

All I get is the following: 

 

This shipping method is currently unavailable. If you would like to ship using this shipping method, please contact us.

 

Any help appreciated with this issue.

 

Thanks in advance.

Re: Security update to 1.9.2.3 and Meanbee Royal Mail

Tried uninstalling and re-installing again, same error with missing require

 

Fatal error: require_once(): Failed opening required '/var/www/html/shop/lib/Meanbee/RoyalmailPHPLibrary/Src/CalculateMethod.php' (include_path='/var/www/html/shop/app/code/local:/var/www/html/shop/app/code/community:/var/www/html/shop/app/code/core:/var/www/html/shop/lib:/usr/local/lib/php') in/var/www/html/shop/app/code/community/Meanbee/Royalmail/Model/Shipping/Carrier/Royalmail.php on line 43

 

copying Src directory to src fixes error this but no shipping method available shows on checkout.

Re: Security update to 1.9.2.3 and Meanbee Royal Mail

Hi Meanbee,

 

Any my word on resolving this as I've tried everything's and now it affecting 2 of my sites, different version of magento 1.9.2.3 and 1.7.0.2 Happy to provide details if that would help.

 

Thanks

Re: Security update to 1.9.2.3 and Meanbee Royal Mail

There was a flaw with the 7405 in which it broke on PHP 5.3. 

 

There should be a new security patch out now (SUPEE-7405 v1.1 or CE1.9.2.4) that will fix this issue. https://www.magentocommerce.com/download

 

I have also alerted Meanbee about this post for them to take a look at anything on their side (they are literally one of the best Magento development firms out there).

 

Just something off topic, I would seriously start working towards getting upgraded to at least PHP 5.4. 5.3 is very old and a lot of companies don't even support it right now.

-Kris
4x Certified, Blogger @ xgento.com

Re: Security update to 1.9.2.3 and Meanbee Royal Mail

We are running php5.6, installed the latests updates but still no shipping method shows ...

 

Sorry, no quotes are available for this order at this time.

 
 

Re: Security update to 1.9.2.3 and Meanbee Royal Mail

Hi, 

 

Apologies that you're experiencing difficulty with the extension! The issue regarding the require that has been experienced was fixed in a recent release of the extension (2.7.3), so you shouldn't be experiencing that problem at all. If you're still experiencing it, please try installing from magento connect instead of manually as remnants of older versions of the extension might be causing it.

 

Regarding no quotes being available at checkout, we often find this is experienced because the countries selected in the admin area of the extension do not match the country selected in checkout. Please can you check that the countries selected in the backend of the extension are the ones that you are selecting on checkout? Apart from that situation, we have not experienced this problem in any other context.

 

Again, apologies of for any difficulty caused by the extension. 

 

Kind regards, 

Meanbee Extension Support

Re: Security update to 1.9.2.3 and Meanbee Royal Mail

To get Magento running on PHP5.6, there are a few hacks you need to do. Have you done those?

 

Magento 1x currently doesn't support PHP 5.6.

-Kris
4x Certified, Blogger @ xgento.com