cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to install SUPEE-7405 1.1 2/23/2016

Unable to install SUPEE-7405 1.1 2/23/2016

I have SUPEE 7405 1.9.1 installed from Jan 20th.  However, when attempting to apply 7405 1.1 for 1.9.1 today 2/24 I'm getting the following error.

 

 

[root@web httpdocs]# sh PATCH_SUPEE-7405_CE_1.9.1.1_v1.1-2016-02-23-07-41-06.sh
Checking if patch can be applied/reverted successfully...
ERROR: Patch can't be applied/reverted successfully.

checking file app/code/core/Mage/Adminhtml/Helper/Sales.php
Reversed (or previously applied) patch detected!  Assume -R? [n]
Apply anyway? [n]
Skipping patch.
1 out of 1 hunk ignored
checking file app/code/core/Mage/Core/Model/Config.php
checking file app/code/core/Mage/Sales/Model/Quote/Item.php
checking file lib/Varien/File/Uploader.php
[root@web httpdocs]#
6 REPLIES

Re: Unable to install SUPREE-7405 1.1 2/23/2016

Hi @pawnbahn

 

Have you applied the previously released SUPEE-7405 patch?

To apply the SUPEE-7405 1.1 patch you have to apply the SUPEE-7405 patch first.

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: Unable to install SUPREE-7405 1.1 2/23/2016

"I have SUPEE 7405 1.9.1 installed from Jan 20th." <--- 1st sentence in original post.  This one?  Yes.

 

PATCH_SUPEE-7405_CE_1.9.1.1_v1-2016-01-20-04-42-03.sh was installed on Jan 20th.

Re: Unable to install SUPREE-7405 1.1 2/23/2016

I am using Magento version 1.9.1.0, but there is no download for it. It skips from ver. 1.9.0.1 to ver. 1.9.1.1. Which one am I supposed to download for 1.9.1.0?

Thanks in advance.

Re: Unable to install SUPEE-7405 1.1 2/23/2016

If you modified the file 

 

checking file app/code/core/Mage/Adminhtml/Helper/Sales.php

So you could run on php 5.3 and be able to view your Sales Orders, you will have to restore that file back to the way that SUPEE-7504 v1.0 would have left it so that SUPEE-7405 v1.1 will apply.

 

This is a patch of a patch. Your Magento installation will need to have all of the files restored to the way that SUPEE-7405 v1.0 would have left them so that SUPEE-7405 v1.1 will apply. Or to put it another way, v1.1 is dependent on v1.0...

 

Same goes for the other thread where everyone edited the file back to the old permissions so images would be viewable.

 

Re: Unable to install SUPEE-7405 1.1 2/23/2016

I am running Magento CE 1.9.2.0  My error is with patching file app/code/core/Mage/Adminhtml/Helper/Sales.php. Below is the error I am getting

sh PATCH_SUPEE-7405_CE_1.9.2.0_v1.1-2016-02-23-07-41-47.sh
 
Checking if patch can be applied/reverted successfully...
ERROR: Patch can't be applied/reverted successfully.
 
patching file app/code/core/Mage/Adminhtml/Helper/Sales.php
Hunk #1 FAILED at 121.
1 out of 1 hunk Failed -- saving rejects to file app/code/core/Mage/Adminhtml/Helper/Sales.php.rej
patching file app/code/core/Mage/Core/Model/Config.php
patching file app/code/core/Mage/Sales/Model/Quote/Item.php
patching file lib/Varien/File/Uploader.php
The previous version was installed by my developer and he said he never change the core file manually which I think is a lie because I checked the core file and noticed $links = array(); was added :
if (!empty($data) && is_array($allowedTags) && in_array('a', $allowedTags)) {
#$links = [];
$links = array();
$i = 1;
$data = str_replace('%', '%%', $data);
$regexp = "/<a\s[^>]*href\s*?=\s*?([\"\']??)([^\" >]*?)\\1[^>]*>(.*)<\/a>/siU";
while (preg_match($regexp, $data, $matches)) {
//Revert the sprintf escaping
$url = str_replace('%%', '%', $matches[2]);
$text = str_replace('%%', '%', $matches[3]);
//Check for an valid url
if ($url) {
$urlScheme = strtolower(parse_url($url, PHP_URL_SCHEME));
if ($urlScheme !== 'http' && $urlScheme !== 'https') {
$url = null;
}
}
//Use hash tag as fallback
if (!$url) {
$url = '#';
}
//Recreate a minimalistic secure a tag
$links[] = sprintf(
'<a href="%s">%s</a>',
htmlspecialchars($url, ENT_QUOTES, 'UTF-8', false),
parent::escapeHtml($text)
);
$data = str_replace($matches[0], '%' . $i . '$s', $data);
++$i;
}
$data = parent::escapeHtml($data, $allowedTags);
return vsprintf($data, $links);
}
return parent::escapeHtml($data, $allowedTags);
}
}
I have delete $links = array(); and remove # infront of the (#$links = []; ) but still given the same error.
Any help please?

Re: Unable to install SUPEE-7405 1.1 2/23/2016

My issue has been resolved and I would like to share my solution.

I downloaded a fresh copy of my Magento files from magentocommerce.com/download then used Notepad++ to compare the difference between the sales.php in the fresh file and the sales.php on my server (after the installation of patch 7405 v1), made changes manually then uploaded the edited sales.php (fresh file) onto my server to replace the one in there.

I then run the Patch 7405 v1.1 command via SSH and everything was fine.

Hope this help