cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading Magento 1.8.1 to current - Patches ?

Upgrading Magento 1.8.1 to current - Patches ?

Sorry for the newbie question, but I have now successfully installed Magento 1.8.1 and I want to upgrade it to the newest version.  I have downloaded the patches, and have been applying them, however I notice that the version of the Magento doesnt change within the Admin panel.  So, I am guessing, that applying the patches doesnt also update the version of the Magento?  I know this might be silly to some, but just trying to understand the software.  So, if this isnt the correct way to update the software, how do I update it to the newest version without losing the current configuration?

Thank you.
Kevin

3 REPLIES

Re: Upgrading Magento 1.8.1 to current - Patches ?

UPDATE:
I ran two new patches, and now I am getting the following errors, any suggestions or help would be great.
   • PATCH_SUPEE-6285_CE_1.8.1.0_v1-2015-07-07-09-06-30.sh
   • PATCH_SUPEE-6285_CE_1.9.1.1_v1-2015-07-10-08-10-09.sh

Thanks,
Kevin


Warning: include_once(/usr/local/www/magento/includes/src/Mage_Core_functions.php): failed to open stream: No such file or directory in /usr/local/www/magento/app/Mage.php on line 36

Warning: include_once(): Failed opening '/usr/local/www/magento/includes/src/Mage_Core_functions.php' for inclusion (include_path='/usr/local/www/magento/includes/src:.:/usr/local/share/pear') in /usr/local/www/magento/app/Mage.php on line 36

Warning: include_once(/usr/local/www/magento/includes/src/Varien_Autoload.php): failed to open stream: No such file or directory in /usr/local/www/magento/app/Mage.php on line 37

Warning: include_once(): Failed opening '/usr/local/www/magento/includes/src/Varien_Autoload.php' for inclusion (include_path='/usr/local/www/magento/includes/src:.:/usr/local/share/pear') in /usr/local/www/magento/app/Mage.php on line 37

Fatal error: Class 'Varien_Autoload' not found in /usr/local/www/magento/app/Mage.php on line 54

Re: Upgrading Magento 1.8.1 to current - Patches ?

Patches only fix some of the errors of the Magento code, not upgrade it. You should perform the upgrade by copy new version into your Magento install. (Please don't do it in production or without backup).



You should have some knowledge before upgrade/patch your Magento, some case it'll be some templates/modules need to modify as well.


About the error you got, I think you didn’t disable compilation before patch. Please try in your ssh/shell access:

 

cd /path/to/magento
php shell/compiler.php disable



Maybe this will help.

Re: Upgrading Magento 1.8.1 to current - Patches ?

Hi Kevin, if you're looking to upgrade to 1.9.2, the latest, you don't need to worry about the patches. All 3 (SUPEE-5344, SUPEE-5994, SUPEE-6285) are included in that version.

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical