cancel
Showing results for 
Search instead for 
Did you mean: 

WANTED: supee 7405(-1) files for 1.6.2 install without SSH

WANTED: supee 7405(-1) files for 1.6.2 install without SSH

Hi guys,

 

Can anybody help me with SUPEE 7405(-1) files for 1.6.2? I don't have SSH access.

 

Thanks,

 

Rickert

5 REPLIES

Re: WANTED: supee 7405(-1) files for 1.6.2 install without SSH

Hi @rickert

 

1) Go to line number 121 in app/code/core/Mage/Adminhtml/Helper/Sales.php file

replace $links = []; with links = array();

 

 

2)Go to app/code/core/Mage/Core/Model/Config.php

Search for this

@param Mage_Core_Model_Config_Base $mergeModel 

and replace with

@param Varien_Simplexml_Config $mergeModel

 

Search for

protected function _makeEventsLowerCase($area, Mage_Core_Model_Config_Base $mergeModel)


and replace with

protected function _makeEventsLowerCase($area, Varien_Simplexml_Config $mergeModel)

 

3) app/code/core/Mage/Sales/Model/Quote/Item.php

- unset($itemOptionValue['qty'], $itemOptionValue['uenc']);
- unset($optionValue['qty'], $optionValue['uenc']);
+ foreach (array('qty', 'uenc', 'form_key') as $key) {
+ unset($itemOptionValue[$key], $optionValue[$key]);
+ }

remove lines which has - in front of them and replace with line having + in front of them

 

 

4)Go to lib/Varien/File/Uploader.php

- chmod($destinationFile, 0640); // remove this line
+ chmod($destinationFile, 0666); // replace with this

- if (!(@is_dir($destinationFolder) || @mkdir($destinationFolder, 0750, true))) { // remove this line
+ if (!(@is_dir($destinationFolder) || @mkdir($destinationFolder, 0777, true))) { // replace with this

Are you using version control? Do you have local setup of your site?
If yes I can suggest alternate method on windows system which do not require ssh access.

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: WANTED: supee 7405(-1) files for 1.6.2 install without SSH

Hi @muk_t,

 

Thanks a lot. Is this a list of supee 7405-1 changes or are 7405 also included in this list?

 

Rickert

Re: WANTED: supee 7405(-1) files for 1.6.2 install without SSH

Hi @rickert

 

SUPEE-7405v1.1 has some updates to the issues faced bu SUPEE-7405 patch.

 

The files which I mentioned are part of SUPEE-7405v1.1 patch.

 

You can download the patch file for your Magento version and open it with a text editor and verify.

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: WANTED: supee 7405(-1) files for 1.6.2 install without SSH

Ok but I'm looking for supee 7405 files as well

Re: WANTED: supee 7405(-1) files for 1.6.2 install without SSH

Is there no file package supplied for SUPEE-7405 on Magento 1.6.2 (without SSH) at all?

 

I reckon there are plenty of installations with 1.6.2 and no SSH access still running.

 

Can anybody provide the package? Please?

 

Rickert