cancel
Showing results for 
Search instead for 
Did you mean: 

Will Upgrading to 1.9.2.3 Avoid SUPEE-7405 Break/Fix Issues on 1.7.0.2?

Will Upgrading to 1.9.2.3 Avoid SUPEE-7405 Break/Fix Issues on 1.7.0.2?

Hi all,

 

After attempting the 7405 patch on my 1.7.0.2 site I found I had the broken Orders page, so reversed the patch. Now that it seems the 7405 patch will not be reissued or revised to avoid the break/fix issues, I am debating whether it is better to do the patch on v 1.7 or upgrade to 1.9.2.3. I would more strongly consider the upgrade to 1.9.2.3 if it avoided the break/fix issues as compared to applying 7405 to 1.7.0.2.

 

Anyone know if there is a behavior difference between the two approaches?

 

Thanks,

Chris

3 REPLIES

Re: Will Upgrading to 1.9.2.3 Avoid SUPEE-7405 Break/Fix Issues on 1.7.0.2?

The break to this page is probably in relation to a PHP 5.3 compatibility issue. An array is declared in the patch using the PHP 5.4 syntax of []. You will therefore have the same issue if you upgrade to 1.9.2.3 as this contains the same change.

 

Assuming it is this problem, you can fix the break by editing:

app/code/core/Mage/Adminhtml/Helper/Sales.php

To replace:

$links = [];

With:

$links = array();

Re: Will Upgrading to 1.9.2.3 Avoid SUPEE-7405 Break/Fix Issues on 1.7.0.2?

See if your hosting provider will upgrade your server to php 5.4 to also circumvent future problems as php has not been being actively upgraded for some time now. There is a php 5.4 support patch available for download in the same place you find the Magento security patches.

 

While you can search the forums and find the fix to make both SUPEE-7405 and Magento 1.9.2.3 work with php 5.3, your overall site security and performance will better served by moving off this outdated version.

Re: Will Upgrading to 1.9.2.3 Avoid SUPEE-7405 Break/Fix Issues on 1.7.0.2?


chiefair wrote:

See if your hosting provider will upgrade your server to php 5.4 to also circumvent future problems as php has not been being actively upgraded for some time now. There is a php 5.4 support patch available for download in the same place you find the Magento security patches.

 

While you can search the forums and find the fix to make both SUPEE-7405 and Magento 1.9.2.3 work with php 5.3, your overall site security and performance will better served by moving off this outdated version.


Agreed. 

 

Instead of PHP 5.4, I'll recommend using an up to date version like PHP 5.5 and above because PHP 5.4 is no longer supported by the PHP team and unless your hosting provider support it themselves (like using HardenedPHP), you are better off going with a supported version for security reasons. 

James Lee | Moderator • Magento Master
See My Recommended Magento Hosting & Security Tips