cancel
Showing results for 
Search instead for 
Did you mean: 

Admin Login is Not Working on Magento ver. 1.9 (and not works with HTTPS)

SOLVED

Admin Login is Not Working on Magento ver. 1.9 (and not works with HTTPS)

We have intermittents bugs when we try to login in admin panel. Sometimes we have "Invalid Form Key. Please refresh he page", but sometimes, we don't have any error messages, but we can't login in admin panel. On the other hand, we can login sometimes without any problem.


We clean caches and sessions in server and in browsers, and use the private navigation, but not always work.


We have several Magento 1.9.X platfforms, and these platfforms have several extensions (not the same), so it's not an extension bug.


Could anybody help us, please?

5 REPLIES

Re: Admin Login is Not Working on Magento ver. 1.9 (and not works with HTTPS)

Hello @esencials

 

 

Issue due to you changed cookie domain.

 

so try with Mozilla browser for same.

 

you can check system health using tool

https://github.com/netz98/n98-magerun

 

n98-magerun.phar sys:check

It will show an error if any configuration error or something.

 

 

If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

 

Re: Admin Login is Not Working on Magento ver. 1.9 (and not works with HTTPS)

Uhm, we checked the configuration with that tool a month ago, when we started with these bugs, but they are platfforms with more of 6 months in production. We haven't changed the configuration, and few months ago they worked ok.

Suddenly, they have this bug, but not all the time, and not in all the PCs. If we clear sessions in server, some users can login, but not all of them.

I think it's a bug with a cookie expiration and new versions of browsers.  

 

Re: Admin Login is Not Working on Magento ver. 1.9 (and not works with HTTPS)

@esencials 

 

yes it happens with mostly chrome browser.

 

 

Re: Admin Login is Not Working on Magento ver. 1.9 (and not works with HTTPS)

I tried a "**bleep**" solution. I inserted a code in login admin panel which clear all cookies and worked in almost all login attemps. 

I know it's not a good idea, because I changed the login admin panel, but it could be a good solution for a patch, don't you?

Re: Admin Login is Not Working on Magento ver. 1.9 (and not works with HTTPS)

Finally we found a sollution: Apache server had X Gigas (RAM) and we gave 2X Gigas. And it's all right