cancel
Showing results for 
Search instead for 
Did you mean: 

BUG: Magento showing subtotals including tax whereas it should show excluding tax.

BUG: Magento showing subtotals including tax whereas it should show excluding tax.

Hello

 

I am using magento 1.9.3.2 and I created 2 different websites. The Catalog Price Scope is set to global and I have products visible on both websites. I would like to show the prices, subtotals and shipping amounts including taxes on one website and excluding taxes on the other website. In the 'Tax' section of the Default config I selected 'Including Tax' for all dropdown lists under 'Price Display Settings', 'Shopping Cart Display Settings' and 'Orders, Invoices, Credit Memos Display Settings'. Then, for one website, I overrode these values by setting the dropdown lists to 'Excluding Tax'. This is however not working as expected, because when I take an order from the admin panel (selecting the website that should show prices without tax), it actually shows the subtotals including taxes. Is this a bug?

 

Regards,

 

Maxime

1 REPLY

Re: BUG: Magento showing subtotals including tax whereas it should show excluding tax.

After investigating, I think this is indeed a bug.. and it is rather critical since it affects the totals. Here is what happen:

1) When taking an order from the backend, the shipping fee will use the settings of the default config, whereas the subtotal of the items will use the configuration of the website from which the order is taken. If the default config and the website have different tax settings, you may end up having totals with mixed amounts (including tax and excluding tax)..

2) After the order is saved, the 'Items Ordered' & 'Order Totals' section will always show prices and amounts using the tax settings of the default config and not the settings of the website from which the order was taken. This is again incorrect.

3) When the invoice is printed, the prices and amounts are displayed using the settings of the website, which is correct.

If anyone can confirm? I hope this will be fixed in a future version..

Regards,

Maxime