cancel
Showing results for 
Search instead for 
Did you mean: 

Bug, when push Buy button

SOLVED

Bug, when push Buy button

Hi

 

Need help with our store www.pernilote.com, when anyone clic "Comprar" (Buy or add to card button), ajax start with loading image but does not stop, join in permanent bug.

Regards

4 REPLIES

Re: Bug, when push Bug button

Hi @Aaron_bcn

If you check your browser console you are getting 500 internal error.

 

Request URL:http://pernilote.com/ajaxcartsuper/ajaxcart/add/uenc/aHR0cDovL3Blcm5pbG90ZS5jb20v/product/1/form_key/VjTNI0uaeKqF3Txg/?callback=jQuery17209736162647604942_1446038663593&_=1446038692289
Request Method:GET
Status Code:500 Internal Server Error

Please provide more details like since when it is happening or what changes were done recently?

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: Bug, when push Buy button

Don't know what happen, I think it's something related with Ajaxcart Super Module.

Re: Bug, when push Buy button

Hi @Aaron_bcn

 

What you should do is turn on Developer mode, or turn on display_error mode.

You can go to public_html/errors, there's local.xml.sample inside, turn it to local.xml.

 

By this way you can see the error.

If not, open Developer mode by opening index.php file in public_html root (same level with app folder).

Comment/Remove out the IF condition to make this line available

Mage::setIsDeveloperMode(true);

 

#ini_set('display_errors', 1); Make this line available too, by remove the #

 

That's how you see the error. How to fix it is another story.

 

Best Regards,

Jimmy.

Re: Bug, when push Buy button

Hi

 

Thanks muk:t and Jiimy, that error 500 ajax server it's fixed. If anyone have that problem, follow that steps for solve it.

 

This error might be caused because you have not set the correct permissions for the magento folders. To solve this go to File Manager and then change the file permission of index.php file from 664 to 644.  Also change the permissions of downloader/index.php file to 644 as well otherwise when you will try to access System > Magento Connect >Magento Connect Manager (after magento installation) by logging to magento admin,  you will get 500 Internal Server Error.

You can also try this tool, it’s a magento cleanup utility. It will set the correct permissions for your complete magento installation:

  1. Download it
  2. Unzip magento-cleanup.php to the root directory of your magento installation
  3. Browse to http://yourdomain.com/magento/magento-cleanup.php

Regards, Aaron