cancel
Showing results for 
Search instead for 
Did you mean: 

Can't update products and attributes in Magento 1.9.2.2

Can't update products and attributes in Magento 1.9.2.2

We just recently moved our Magento 1.9.2.2 site to a new server. We tried a few tests and noticed that we can't update products and attributes in the backend. The page refreshes but there is no success message. We checked our error_logs and this is the error:

 

2016-04-08T09:01:33+00:00 ERR (3): Warning: array_key_exists() expects parameter 2 to be array, null given  in /var/www/vhosts/xxx/xxx/app/code/core/Mage/Adminhtml/controllers/Catalog/ProductController.php on line 507
2016-04-08T09:01:33+00:00 ERR (3): Warning: array_key_exists() expects parameter 2 to be array, null given  in /var/www/vhosts/xxx/xxx/app/code/core/Mage/Adminhtml/controllers/Catalog/ProductController.php on line 507
2016-04-08T09:01:33+00:00 ERR (3): Warning: array_key_exists() expects parameter 2 to be array, null given  in /var/www/vhosts/xxx/xxx/app/code/core/Mage/Adminhtml/controllers/Catalog/ProductController.php on line 507
2016-04-08T09:01:33+00:00 ERR (3): Warning: array_key_exists() expects parameter 2 to be array, null given  in /var/www/vhosts/xxx/xxx/app/code/core/Mage/Adminhtml/controllers/Catalog/ProductController.php on line 507
2016-04-08T09:01:33+00:00 ERR (3): Warning: array_key_exists() expects parameter 2 to be array, null given  in /var/www/vhosts/xxx/xxx/app/code/core/Mage/Adminhtml/controllers/Catalog/ProductController.php on line 507
2016-04-08T09:01:33+00:00 ERR (3): Warning: array_key_exists() expects parameter 2 to be array, null given  in /var/www/vhosts/xxx/xxx/app/code/core/Mage/Adminhtml/controllers/Catalog/ProductController.php on line 507
2016-04-08T09:01:33+00:00 ERR (3): Recoverable Error: Argument 1 passed to Varien_Object::addData() must be of the type array, null given, called in /var/www/vhosts/xxx/xxx/app/code/core/Mage/Adminhtml/controllers/Catalog/ProductController.php on line 514 and defined  in /var/www/vhosts/xxx/xxx/lib/Varien/Object.php on line 243
2016-04-08T09:01:33+00:00 ERR (3): Warning: Invalid argument supplied for foreach()  in /var/www/vhosts/xxx/xxx/lib/Varien/Object.php on line 245

 

We have tried running the compiler as well as clearing the cache but it didn't work. The site was also working properly on our previous server.

 

Anyone that can help me out with this is much, much appreciated.

 

Thanks!

6 REPLIES

Re: Can't update products and attributes in Magento 1.9.2.2

yes in old version of magento their is a update problem, After updating the server of magento with new server no theris is no problem with this program for more details visit our website:- http://rakabroad.in

Re: Can't update products and attributes in Magento 1.9.2.2

I appreciate your reply but I don't think there's any relevance with it to my problem.

 

I've had this problem for almost a month now. I understand this is a rare issue with Magento and I can't find any posts that has a solution with it. If anyone might have an idea with this it would be really much appreciated.

Re: Can't update products and attributes in Magento 1.9.2.2

Re: Can't update products and attributes in Magento 1.9.2.2

Tried that one, but unfortunately it doesn't work for me Smiley Sad

Re: Can't update products and attributes in Magento 1.9.2.2

I had the same problem. It turned out to be an .htaccess problem. I recognized several 301s which stripped away the form data.

This is what I had in my .htaccess

 

 

## remove /index.php/ from URL (not for admin area)

    RewriteCond %{REQUEST_URI} !/index\.php/admin/.*$
    RewriteRule ^(index.php/)(.*)$  $2 [L,R=301]

 

 

This lines helped me to get rid of the /index.php/ in the paths. As you see I excluded this from the admin urls. However when I decided to rename my admin path for security reasons, the rewrite started to work for the admin area as well.

Re: Can't update products and attributes in Magento 1.9.2.2

@geri7777 That worked for me! I had in my htaccess file the line 

redirect 301 /index.php/ http://sitename.com/ 

Removed it and now I can save everything from the admin panel. 

Thank you!