cancel
Showing results for 
Search instead for 
Did you mean: 

Cant upgrade Magento 1.4.0.1 ..

Cant upgrade Magento 1.4.0.1 ..

 Hi

 

I am trying to upgrade a magento 1.4.0.1 to a newer version, but each time i do a check for newer version in the connect manager, i get a pear error, googling dosent seem to find anything, does anyone know how to fix this?

/var/www/mysite.com/public_html/downloader/Maged/Model/Pear.php on line 142

Backtrace:

0 /var/www/mysite.com/public_html/downloader/Maged/Model/Pear.php(142): mageCoreErrorHandler(2, 'Invalid argumen...', '/var/www/deepoc...', 142, Array)

1 /var/www/mysite.com/public_html/downloader/template/pear/packages.phtml(49): Maged_Model_Pear->getAllPackages()

2 /var/www/mysite.com/public_html/downloader/Maged/View.php(59): include('/var/www/deepoc...')

3 /var/www/mysite.com/public_html/downloader/Maged/Controller.php(120): Maged_View->template('pear/packages.p...')

4 /var/www/mysite.com/public_html/downloader/Maged/Controller.php(368): Maged_Controller->pearPackagesAction()

5 /var/www/mysite.com/public_html/downloader/Maged/Controller.php(183): Maged_Controller->dispatch()

6 /var/www/mysite.com/public_html/downloader/index.php(35): Maged_Controller::run()

7 {main}

 

I have tried to reset all folder permissions, but that dident solve anything. Can any one point me in the right direction?

1 REPLY

Re: Cant upgrade Magento 1.4.0.1 ..

Since 1.4.0.1 there has been a lot of changes. It will prove very difficult to get the upgrade to work correctly.


In all honest, i would just suggest a complete rebuild & import of catalog, customers & sales.

 

 


Freelance Web Developer - Graphic Designer - SEO Analyst
Conor Rhys Tomkins