Showing results for 
Search instead for 
Did you mean: 

Catalog Price Rule don't work

Catalog Price Rule don't work

We have NEVER been able to get catalog price rules to work, and we've been on Magento CE for 8 years. I assumed that it was because we had been using a lot of the same theme code and just upgrading from edition to edition for years and that there was something, somewhere that dated back to the early days of Magento and writing custom extensions that was the problem. But we're on now and we did a clean install and just upgraded the database and then reapplied all of our extensions. It was a big job, not without complications, but we wanted a clean start, hoping that some of our persistent bugs would go away.


We still cannot get catalog price rules to work. We've created rules, saved and applied, applied rules, checked cron, checked to be sure that the two different cron jobs that have to run in sequence have the default times set on them, flushed cache, indexed, waited overnight, or even for days, and nothing. We cannot get a catalog price rule to apply. We've tried different customer groups, different date settings, different action settings. Nothing seems to work. We can't even get the "catalogrule_product" or "catalogrule_product_price" tables in the database to populate. They always show "no rows". 


What are we doing wrong? It doesn't seem like anybody else has the problem that we have with this. Can you help me troubleshoot this???


Re: Catalog Price Rule don't work



You can also check this article -

maybe you have some particular settings, like for configurable products

Example of rule settings will be helpful.

Re: Catalog Price Rule don't work

Ok, well I've tried all sorts of settings. Right now, I've got it active, selected for one website, all customer groups are selected, I have a from date in the past and a to date a year in the future with a priority 0. I've also tried it with individual customer groups, starting dates, but no end dates, and no dates at all. 


I've got three rules I'm testing right now with different condition. One "Any of these conditions are TRUE" and "SKU is" with an exact sku pulled from the list. One is "category is", with a category pulled from the list.  One is "name contains" with a couple of different keywords that I have tried. I've tried all of these with "Any" and with "All". I only have one condition set for each rule. I have checked the different attributes to make sure they could be used for promo rules and they are set to yes. I don't know what I'm doing wrong. I've followed the instructions to the letter from multiple sites to get this to work and still cannot get it going. 

Re: Catalog Price Rule don't work

Have you tried changing the category to "is one of" I am no expert but the voice in my had tells me "is" would only return true if the product is only assigned to the category in question but someone else might be able to confirm that.

Maybe take a screen shot of the 3 panels and share them with us so someone could try to replicate it for you?

Re: Catalog Price Rule don't work

I understand what you're saying about a rule not working properly because of some kind of setting like that. We encounter that all of the time with shopping cart rules. The problem we're facing here is that we can't even get rules to write to the categoryrule_product or categoryrule_product_price or categoryrule_affected_products tables. The rules are writing to the other categoryrule tables like website and group, but not those three. Is it possible to have a read only table in a database? And if a table is read only or my user doesn't have permissions to write to it, how can I find that out?

Re: Catalog Price Rule don't work

In my case they were not working because of incorrectly configured proxy servers. In fact, they probably were incorrect, don't know how else to explain it.

Re: Catalog Price Rule don't work

@stevetallent did you find a solution to your problem? I am really interested on this! | Web Applications, Crafted with Care

Re: Catalog Price Rule don't work

We haven't gotten it to work. My suspicion is that it is an extension. We are about to abandon several extensions and then we will start working on it again. Honestly, we have never gotten them to work since the days of 1.4. With our last round of testing, we were going into the database tables and the rule was not populating the critical table when cron ran.

Re: Catalog Price Rule don't work

Some progress here.

We have intermittent success with the price rules, sometimes they work and sometimes they just fail.  I've never been able to understand why.

I thought it was related to using multiple categories in my rule so have recently been using a basic rule with 1 category.  I then add products to this rule and it works, until the weekend!

example Rule = 20%.

On the weekend I added some new Rules 25% and 30% and added products to them.  Today I realized none of the rules were working.  No wonder no sales!

I was looking at an article which was showing some SQL to see if the catalogrule_product was being populated.  They were populated.  I happened to browse the rules table itself and found I had added "descriptions" to the new rules.  These descriptions contained "%" signs.

I edited the rule and removed the descriptions which had % signs.  I had other rules with descriptions.

Rules are now working again and products are discounted on front end.


Re: Catalog Price Rule don't work

@budjik this was the exact reason that my promotional discount would not apply to our products. I made 2 rules that were exactly the same and only deleted the"%" symbol from the descriptions pane and the rule displayed properly. What a small bug to cause such a big problem. Thanks budjjik for posting this.