cancel
Showing results for 
Search instead for 
Did you mean: 

Catalog URL Rewrites Error

Catalog URL Rewrites Error

Running Magento 1.9.2.1 & PHP 5.5

 

Initially i first noticed a problem when the re-indexing of Catalog URL Rewrites became stuck on "processing" for days.

 

I then ran the SSH command:

 

php indexer.php -reindex catalog_url

 

This returned the following: 

 

PHP Fatal error: Uncaught exception 'Zend_Exception' with message 'dbModel read resource does not implement Zend_Db_Adapter_Abstract' in /root/lib/Varien/Data/ Collection/Db.php:187
Stack trace:
#0 /root/app/code/core/Mage/Core/Model/Resource/Db/Collection/Abstract.php(134): Varien_Data_Collection_Db->setConnection(false)
#1 /root/app/code/core/Mage/Core/Model/Config.php(1348): Mage_Core_Model_Resourc e_Db_Collection_Abstract->__construct(Array)
#2 /root/app/code/core/Mage/Core/Model/Config.php(1380): Mage_Core_Model_Config- >getModelInstance('index_resource/...', Array)
#3 /root/app/Mage.php(490): Mage_Core_Model_Config->getResourceModelInstance('in dex/process_c...', Array)
#4 /root/app/code/core/Mage/Index/Model/Indexer.php(67): Mage::getResourceModel( 'index/process_c...')
#5 /root/app/code/core/Mage/Core/Model/Config.php(1348): Mage_Index_Model_Indexe r->__construct(Array)
#6 /root/app/Mage.php(462): Mage_Core_Model_Config->getModelInstance('index/inde xer', Array)
#7 /root/app/Mage.php(476): Mage::getModel('index/indexer', Arr in /root/lib/Var ien/Data/Collection/Db.php on line 187

 

I've tried researching the problem, so far the only answers I've found are:

 

"It's a permission problem.

chmod -R 777 var/*

should solve it. Try removing var/cache/* first."

 

So I've tried the above, yet the error still occurs.

 

Can anyone shed any light towards a solution? 

I appreciate any help with this.

Thanks

Tags (1)