cancel
Showing results for 
Search instead for 
Did you mean: 

Configurable Products won't work in 1.9.3 (.1)

Configurable Products won't work in 1.9.3 (.1)

Hey everybody,

I tried to upgrade from 1.9.2.4 to 1.9.3 but I get problems with my configurable products. When trying to show the configurable product frontend page that worked perfectly on 1.9.2.4 it won't show the configurable options and no price etc of the product in 1.9.3 anymore. The page stops loading at the point where the option dropdowns should be displayed and the rest won't be loaded anymore. I use Porto theme in the latest version. Are there any hints or is there anything I'm missing for the update on 1.9.3? 

 

Best regards, Stephan

 

configurable bug

9 REPLIES

Re: Configurable Products won't work in 1.9.3 (.1)

i had a similar issiue

 

1) you must add varien/product_options.js  file in your theme's local.xml file 

   a) you should learn your theme's name in admin page > system > configuration > general > design > themes > templates (my setting is porto_child, it is my child theme name)

   b) and add this line (<action method="addJs"><script>varien/product_options.js</script></action>) to head referance in app>design>frontend>smartwave(my vendor name, yours may be different)>porto_child>local.xml

 

if not resolve yours problem, you can try to add jquery.lazyload.min.js file in local.xml with same way (it's solve my problem) i found this file in my jquery folder js>smartwave>jquery>plugins>lazyload>jquery.lazyload.min.js

 

i hope, its work for you.

Re: Configurable Products won't work in 1.9.3 (.1)

Hey, thank you for your detailed response. I finally tried to update from 1.9.2.4 to magento 1.9.3.3 today and updated Porto to 2.5.0 too. But I still have the same mistake. Checked the local.xml, the js files seem to be entered. Any further suggestions on this? 

 

Re: Configurable Products won't work in 1.9.3 (.1)

Okay, it's getting even stranger now:

 

When opening the product details there is a fatal error shown: 

Fatal error: Call to a member function getIsInStock() on null in /usr/www/users/***/raed-slacklines.com/app/code/core/Mage/Catalog/Block/Product/View/Type/Configurable.phpon line 158

 

Can anyone please provide me some hints what this means and how to handle this? The only thing changed so far is an upgrade from 1.9.2.4 to 1.9.3.3 

Re: Configurable Products won't work in 1.9.3 (.1)

Even I am facing same issue.

any solution?

Re: Configurable Products won't work in 1.9.3 (.1)

Still the same here. I even tried an update via FTP yesterday, the problem still occurs. Any ideas? Is this a bug or do we miss a point?

Re: Configurable Products won't work in 1.9.3 (.1)

Did you solved the problem? Getting this error till I updated to 1.9.3.6. Any help will be more than great!!!

Re: Configurable Products won't work in 1.9.3 (.1)

I could't get it solved yet. Had to go back to 1.9.2 to keep the configurables working :/

Re: Configurable Products won't work in 1.9.3 (.1)

Does anyone know any hints on this issue? :/

Re: Configurable Products won't work in 1.9.3 (.1)

does anyone has the same problem and solved it??? Adding the JS doesnt solved my pbs.

 

Thanks!!!