cancel
Showing results for 
Search instead for 
Did you mean: 

ConfigurableSwatches error in sytem.log

ConfigurableSwatches error in sytem.log

Hi,

 

I have all my system.log file full of this error:

 

 

2017-06-14T23:13:59+00:00 ERR (3): Warning: in_array() expects parameter 2 to be array, null given in /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/ConfigurableSwatches/Helper/Productimg.php on line 345
2017-06-14T23:13:59+00:00 ERR (3): Warning: array_merge_recursive() expects at least 1 parameter, 0 given in /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/ConfigurableSwatches/Helper/Productimg.php on line 336
2017-06-14T23:13:59+00:00 ERR (3): Warning: array_unique() expects parameter 1 to be array, null given in /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/ConfigurableSwatches/Helper/Productimg.php on line 337
2017-06-14T23:13:59+00:00 ERR (3): Warning: array_map(): Argument #2 should be an array in /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/ConfigurableSwatches/Helper/Productimg.php on line 340
2017-06-14T23:13:59+00:00 ERR (3): Warning: array_merge(): Argument #1 is not an array in /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/ConfigurableSwatches/Helper/Productimg.php on line 340

 

somebody help me?

 

regards!

6 REPLIES

Re: ConfigurableSwatches error in sytem.log

Hi @antrax13,

 

I get the same errors on our site.  Did you get any joy with solving this?

 

Cheers,

Tim

Re: ConfigurableSwatches error in sytem.log

Just found the cause for the error.

 

From a previous version of Magento, I had a fix to the sort order of the config products.  To fix, I deleted the old fix from /app/code/local/Catalog/Model/Resource/Product/Type/Configurable/Attribute/Collection.php

 

Ignore that, the error is still appearing in the log.

Re: ConfigurableSwatches error in sytem.log

Hello, I have same problem.

Re: ConfigurableSwatches error in sytem.log

For all who have this issue, can you perform a small test?

 

  1. Disable 3rd-party modules.
  2. Change your theme to RWD.

Then test again the configurable swatches

Can you share which version of Magento are you using?

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: ConfigurableSwatches error in sytem.log

I am using 1.9.2.4 my problem still continue

Re: ConfigurableSwatches error in sytem.log

Can you share your Swatches configuration?

I got a few stores using this feature and can't reproduce the problem.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"