cancel
Showing results for 
Search instead for 
Did you mean: 

Customer Edit There has been an error processing your request

Customer Edit There has been an error processing your request

Whenever I got to edit a customer file I get this error:

There has been an error processing your request
Source model "pushnotification/entity_resource" not found for attribute "pushnotification"
Trace: #0 /home/macleods/public_html/app/code/core/Mage/Eav/Model/Entity/Attribute/Abstract.php(387): Mage::exception('Mage_Eav', 'Source model "p...') #1 /home/macleods/public_html/app/code/core/Mage/Adminhtml/Block/Widget/Form.php(201): Mage_Eav_Model_Entity_Attribute_Abstract->getSource() #2 /home/macleods/public_html/app/code/core/Mage/Adminhtml/Block/Customer/Edit/Tab/Account.php(75): Mage_Adminhtml_Block_Widget_Form->_setFieldset(Array, Object(Varien_Data_Form_Element_Fieldset), Array) #3 /home/macleods/public_html/app/code/core/Mage/Adminhtml/Block/Customer/Edit/Tabs.php(58): Mage_Adminhtml_Block_Customer_Edit_Tab_Account->initForm() #4 /home/macleods/public_html/app/code/community/POS/System/Adminhtml/Block/Customer/Edit/Tabs.php(9): Mage_Adminhtml_Block_Customer_Edit_Tabs->_beforeToHtml() #5 /home/macleods/public_html/app/code/core/Mage/Core/Block/Abstract.php(862): POS_System_Adminhtml_Block_Customer_Edit_Tabs->_beforeToHtml() #6 /home/macleods/public_html/app/code/core/Mage/Core/Block/Text/List.php(43): Mage_Core_Block_Abstract->toHtml() #7 /home/macleods/public_html/app/code/core/Mage/Core/Block/Abstract.php(863): Mage_Core_Block_Text_List->_toHtml() #8 /home/macleods/public_html/app/code/core/Mage/Core/Block/Abstract.php(582): Mage_Core_Block_Abstract->toHtml() #9 /home/macleods/public_html/app/code/core/Mage/Core/Block/Abstract.php(526): Mage_Core_Block_Abstract->_getChildHtml('left', true) #10 /home/macleods/public_html/app/design/adminhtml/default/default/template/page.phtml(58): Mage_Core_Block_Abstract->getChildHtml('left') #11 /home/macleods/public_html/app/code/core/Mage/Core/Block/Template.php(241): include('/home/macleods/...') #12 /home/macleods/public_html/app/code/core/Mage/Core/Block/Template.php(272): Mage_Core_Block_Template->fetchView('adminhtml/defau...') #13 /home/macleods/public_html/app/code/core/Mage/Core/Block/Template.php(286): Mage_Core_Block_Template->renderView() #14 /home/macleods/public_html/app/code/core/Mage/Adminhtml/Block/Template.php(81): Mage_Core_Block_Template->_toHtml() #15 /home/macleods/public_html/app/code/core/Mage/Core/Block/Abstract.php(863): Mage_Adminhtml_Block_Template->_toHtml() #16 /home/macleods/public_html/app/code/core/Mage/Core/Model/Layout.php(555): Mage_Core_Block_Abstract->toHtml() #17 /home/macleods/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(390): Mage_Core_Model_Layout->getOutput() #18 /home/macleods/public_html/app/code/core/Mage/Adminhtml/controllers/CustomerController.php(151): Mage_Core_Controller_Varien_Action->renderLayout() #19 /home/macleods/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(419): Mage_Adminhtml_CustomerController->editAction() #20 /home/macleods/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('edit') #21 /home/macleods/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(176): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http)) #22 /home/macleods/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch() #23 /home/macleods/public_html/app/Mage.php(683): Mage_Core_Model_App->run(Array) #24 /home/macleods/public_html/index.php(97): Mage::run('', 'store') #25 {main}
Tags (2)
4 REPLIES

Re: Customer Edit There has been an error processing your request

Hi @paulg007,

 

It seems you're using an attribute with a specific source model but the source model isn't present anymore. This sound familiar to you?

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Customer Edit There has been an error processing your request

Yes I believe there must be a bably uninstalled plugin. Thats left some code behind and can't find the file.

How would I got about fixing this?

Re: Customer Edit There has been an error processing your request

I did some digging around ive lost the customer, "manage attributes" tab

so thats why its throwing up attribute errors. Just dont know how to load it back in. Unless I overwrite the admin core modules via ftp using the original magento v1.7 installtion files.

Re: Customer Edit There has been an error processing your request

Hi @paulg007,

 

Well, I'm not sure hwo to answer the whole question because I don't know the state of yoru code but with the attribute issue you can try to edit the eav_attribute and change the source_model for your attribute to null.

At least you're pretty sure and can rebuild the source model.

There isn't an easy answer because I should check the code before.

 

Remember to make a backup before any significant change.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"