cancel
Showing results for 
Search instead for 
Did you mean: 

Customer Registration not working in 1.9.2.2

SOLVED

Customer Registration not working in 1.9.2.2

I upgraded to 1.9.2.2 yesterday morning and I received reports from customers saying they couldn't register on the website. Thought it was just user error, but then I tried it myself and it was indeed broken.

 

After filling our first name, last name, password, then clicking the submit button, it just refreshes the screen and does not complete. Anyone else having this issue?

40 REPLIES

Re: Customer Registration not working in 1.9.2.2

If you're using a custom theme, make sure you update the customer registration form template, which is updated in Magento 1.9.2.2 (and security patch SUPEE-6788). It is located in:

 

template/customer/form/register.phtml (line 46)

 

OR

 

template/persistent/customer/form/register.phtml (line 45)

 

They added the following in the update:

 

 

<input type="hidden" name="form_key" value="<?php echo Mage::getSingleton('core/session')->getFormKey() ?>" />

 

which makes sure the now required form_key is submitted along with the registration data.

 

Please note that the file resetforgottenpassword.phtml is also updated, so you check the password reset functionality as well.

 

Did I help you solve your problem? Click Accept as Solution!
DudeSquare Web Development

Re: Customer Registration not working in 1.9.2.2

I have this issue too but adding the line of code didn't fix the issue.  I've tried the default rwd template just in case there are other compatibility issues here and the problem exists in that template too.  The problem only came to light after the 1.9.2.2 update.  Any ideas?

Re: Customer Registration not working in 1.9.2.2

Yeah, i made that fix, but still no luck. 

 

I think it's a deeper 1.9.2.2 issue. I have 2 websites on my magento installation, both use custom themes. 1 of those did NOT override the register.phtml file, while the other did. Both websites are having issues with registration, so this solution is not working. 

Re: Customer Registration not working in 1.9.2.2

Did you check the frontend HTML to see if this line is actually added to the form? Lots of 3rd party extensions also override the register.phtml file. What's the url of your Magento shop?

Did I help you solve your problem? Click Accept as Solution!
DudeSquare Web Development

Re: Customer Registration not working in 1.9.2.2

Yeah, i just looked and it's NOT showing up on the frontend.

 

I found the extension causing the issue! http://www.magentocommerce.com/magento-connect/manage-customer-attributes.html

 

I've temporarily disabled the extension. Waiting to hear back from the developer about it. 

Re: Customer Registration not working in 1.9.2.2

Assuming you emptied your cache properly, that means your shop is using a non-default register.phtml. If you turn on Template Path Hints you can see which template is used for the registration form. Do you know how to turn on the Template Path Hints?

Did I help you solve your problem? Click Accept as Solution!
DudeSquare Web Development

Re: Customer Registration not working in 1.9.2.2

Good call! I didn't even think about doing that. 

 

Turns out that the extension that I identified was overriding the register.phtml file. I just added the snippet of code and everything works again!!!!

Re: Customer Registration not working in 1.9.2.2

Good to hear! Could you please accept my solution, so other people can see this topic is resolved?

 

@Borrodin Does this solve your problem as well?

Did I help you solve your problem? Click Accept as Solution!
DudeSquare Web Development

Re: Customer Registration not working in 1.9.2.2

Hi All,

Thanks for the feedback.  No it hasn't solved my problem.  I have 3 stores running now and they all have the same problem:

1. Custom theme that overrides register.phtml.  It didn't have the updated line so I added it.  It still has the problem.

2. Custom theme that uses default register.phtml.  Still has the problem but I checked that the default file has been updated (it has).

3. Default rwd theme (just for testing) and has the problem also.

 

Interestingly, if a customer chooses to register as part of the checkout process, that works fine.  The forgot password script works fine, as do all the other regular scripts, such as login.  It's literally just the manual register option, but on all my sites.