Showing results for 
Search instead for 
Did you mean: 

Error after System-Copy

Error after System-Copy


I just copied a whole magento system to a new hoster.

I get this first error:


SQLSTATE[42S02]: Base table or view not found: 1146 Table 'usr_p271648_1.log_visitor_info' doesn't exist

#0 /html/magento/lib/Varien/Db/Statement/Pdo/Mysql.php(110): Zend_Db_Statement_Pdo->_execute(Array)
#1 /html/magento/lib/Zend/Db/Statement.php(300): Varien_Db_Statement_Pdo_Mysql->_execute(Array)
#2 /html/magento/lib/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#3 /html/magento/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('DESCRIBE `log_v...', Array)
#4 /html/magento/lib/Varien/Db/Adapter/Pdo/Mysql.php(419): Zend_Db_Adapter_Pdo_Abstract->query('DESCRIBE `log_v...', Array)

How I get this table back?


Greetz & Thanks.


Re: Error after System-Copy


Re: Error after System-Copy

I have the same error message, but in my case I couldn't even start yet


QLSTATE[42S02]: Base table or view not found: 1146 Table 'solemake.index_process' doesn't exist, query was: SELECT `index_process`.`indexer_code` FROM `index_process`
Trace: #0 /home/papermake/public_html/ Zend_Db_Statement_Pdo->_execute(Array) #1 /home/papermake/public_html/ Varien_Db_Statement_Pdo_Mysql->_execute(Array) #2 /home/papermake/public_html/ Zend_Db_Statement->execute(Array) #3 /home/papermake/public_html/ Zend_Db_Adapter_Abstract->query('SELECT `index_p...', Array) #4 /home/papermake/public_html/ Zend_Db_Adapter_Pdo_Abstract->query('SELECT `index_p...', Array) #5 /home/papermake/public_html/ Varien_Db_Adapter_Pdo_Mysql->query(Object(Varien_Db_Select), Array) #6 /home/papermake/public_html/ Zend_Db_Adapter_Abstract->fetchCol(Object(Varien_Db_Select)) #7 /home/papermake/public_html/ Mage_Index_Model_Resource_Setup->_syncIndexes() #8 /home/papermake/public_html/ Mage_Index_Model_Resource_Setup->applyUpdates() #9 /home/papermake/public_html/ Mage_Core_Model_Resource_Setup::applyAllUpdates() #10 /home/papermake/public_html/ Mage_Core_Model_App->_initModules() #11 /home/papermake/public_html/ Mage_Core_Model_App->run(Array) #12 /home/papermake/public_html/ Mage::run('', 'store') #13 {main}

Re: Error after System-Copy



I am having the EXACT error!


Did you fix this?


Could you PLEASE share the solution?



Re: Error after System-Copy

This worked for me:


CREATE TABLE `log_visitor_info` (
`visitor_id` bigint(20) unsigned NOT NULL DEFAULT '0' COMMENT 'Visitor ID',
`http_referer` varchar(255) DEFAULT NULL COMMENT 'HTTP Referrer',
`http_user_agent` varchar(255) DEFAULT NULL COMMENT 'HTTP User-Agent',
`http_accept_charset` varchar(255) DEFAULT NULL COMMENT 'HTTP Accept-Charset',
`http_accept_language` varchar(255) DEFAULT NULL COMMENT 'HTTP Accept-Language',
`server_addr` bigint(20) DEFAULT NULL COMMENT 'Server Address',
`remote_addr` bigint(20) DEFAULT NULL COMMENT 'Remote Address',
PRIMARY KEY (`visitor_id`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COMMENT='Log Visitor Info Table';


It looks like the back-ticks will copy correctly from here, but in case there is any trouble you can copy from here:



Re: Error after System-Copy

That's don't works for me Smiley Sad Someone else ? I have this problem since 2 week... Smiley Sad