cancel
Showing results for 
Search instead for 
Did you mean: 

Error connecting EOne SmartConnect to Magento SOAP interface

SOLVED

Error connecting EOne SmartConnect to Magento SOAP interface

Magento V 1.9.2.4 When I try to connect the SmartConnect soap client to my Magento server i am getting the error:

Exception has been thrown by the target of an invocation.
SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://www.myurl.com:443/index.php/api/v2_soap/index/?wsdl=1'
: failed to load external entity "https://www.myurl.com:443/index.php/api/v2_soap/index/?wsdl=1"

 

A posting I found seemed to indicate that the server could not access itself. It said to make sure that your have an entry in \etc\host that points to itself. I have done so. It also mentioned using curl to test the connection.

Using curl returned the following:

~$ curl https://www.myurl.com:443/index.php/api/v2_soap/?wsdl=1 curl: 
(60) SSL certificate problem: unable to get local issuer certificate More details here:
http://curl.haxx.se/docs/sslcerts.html
curl performs SSL certificate verification by default, using a "bundle" of
Certificate Authority (CA) public keys (CA certs).
If the default bundle file isn't adequate, you can specify an alternate
file using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in the
bundle, the certificate verification probably failed due to a problem with the
certificate (it might be expired, or the name might not match the
domain name in the URL). If you'd like to turn off curl's verification
of the certificate, use the -k (or --insecure) option.

When I used curl with the -k option, I get the wsdl information returned correctly.

 

At this point I am not sure what to do. My ssl has been working fine with my Storefront for months.

Any suggestions would be appreciated.

Tags (1)
2 REPLIES

Re: Error connecting EOne SmartConnect to Magento SOAP interface

It may be that your SSL certificate is not chained correctly.

Use https://www.sslshopper.com/ssl-checker.html and put your domain name into it in order to check if SSL is set up correctly.

If this response was helpful to you, consider giving kudos to this post.
If this response solved your problem, click accept as solution to help others solve this issue

Re: Error connecting EOne SmartConnect to Magento SOAP interface

It turns out this was the case. While I had installed my certificate correctly I did not add in the intermediary certificate bundle. For those that are using Ubuntu on an AWS server with the Bitnami bundle the file that needs to be modified is: /opt/bitnami/apache2/conf/bitnami/bitnami-apps-vhosts.conf

The section I had to modify was:

<VirtualHost *:443>
    ServerName xxxxx.com
    ServerAlias www.xxxxx.com
    DocumentRoot "/opt/bitnami/apps/magento/htdocs"
    SSLEngine on
    SSLCertificateFile "/opt/bitnami/apps/magento/conf/certs/xxxxx.crt"
    SSLCertificateKeyFile "/opt/bitnami/apps/magento/conf/certs/xxxxx.key"
    SSLCertificateChainFile "/opt/bitnami/apps/magento/conf/certs/gd_bundle-g2-g1.crt" 
    
    Include "/opt/bitnami/apps/magento/conf/httpd-app.conf"
</VirtualHost>