cancel
Showing results for 
Search instead for 
Did you mean: 

Errors after backup restore

Errors after backup restore

Hi,

I did a roleback from a backup and now I am getting these errors.  Can anyone help.

thanks,

Justin

 

Warning: include_once(Mage/Core/functions.php): failed to open stream: No such file or directory in /home/gomailboxart/public_html/app/Mage.php on line 49

Warning: include_once(): Failed opening 'Mage/Core/functions.php' for inclusion (include_path='/home/gomailboxart/public_html/app/code/local:/home/gomailboxart/public_html/app/code/community:/home/gomailboxart/public_html/app/code/core:/home/gomailboxart/public_html/lib:.:/usr/lib/php:/usr/local/lib/php') in /home/gomailboxart/public_html/app/Mage.php on line 49

Warning: include_once(Varien/Autoload.php): failed to open stream: No such file or directory in /home/gomailboxart/public_html/app/Mage.php on line 50

Warning: include_once(): Failed opening 'Varien/Autoload.php' for inclusion (include_path='/home/gomailboxart/public_html/app/code/local:/home/gomailboxart/public_html/app/code/community:/home/gomailboxart/public_html/app/code/core:/home/gomailboxart/public_html/lib:.:/usr/lib/php:/usr/local/lib/php') in /home/gomailboxart/public_html/app/Mage.php on line 50

Fatal error: Class 'Varien_Autoload' not found in /home/gomailboxart/public_html/app/Mage.php on line 53

2 REPLIES

Re: Errors after backup restore

Hi @fathershrubb, what version of Magento did you roll back to and from? Also, what process did you use to revert to your backup?

--

Community Manager, Magento
Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: https://magento.com/resources/technical

Re: Errors after backup restore

Hello.

I'm working with Magento v1.9.3.1 and i had the same problem described above after i restored backup. I restored the backup in System/Tools/Backup and after i clicked in restore link, showed the follow error below:

 

There has been an error processing your request

 

Error in file: "public_html/app/code/local/Bc/Manufacturer/sql/manufacturer_setup/mysql4-install-0.1.0.php" - SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'manufacturer' already exists
Trace: #0 public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(644): Mage::exception('Mage_Core', 'Error in file: ...') #1 public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(421): Mage_Core_Model_Resource_Setup->_modifyResourceDb('install', '', '1.1.10') #2 public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(327): Mage_Core_Model_Resource_Setup->_installResourceDb('1.1.10') #3 public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates() #4 public_html/app/code/core/Mage/Core/Model/App.php(428): Mage_Core_Model_Resource_Setup::applyAllUpdates() #5 public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Model_App->_initModules() #6 public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array) #7 public_html/index.php(83): Mage::run('', 'store') #8 {main}
What could be this? Anyone could help me? Thanks a lot. Smiley Happy