cancel
Showing results for 
Search instead for 
Did you mean: 

Fatal error: Declaration of Zend_Pdf_FileParserDataSource_File::__construct()

Fatal error: Declaration of Zend_Pdf_FileParserDataSource_File::__construct()

I get this error when I try to print an invoice:

 

Fatal error: Declaration of Zend_Pdf_FileParserDataSource_File::__construct() must be compatible with Zend_Pdf_FileParserDataSource::__construct() in /home/theanima/public_html/lib/Zend/Pdf/FileParserDataSource/File.php on line 41

 

I believe that I have upgraded to CE1.9 but it says it is still CE1.5.1 on the bottom of the window.

1 REPLY

Re: Fatal error: Declaration of Zend_Pdf_FileParserDataSource_File::__construct()

 

Fixed it by change in this function 

lib/Zend/Pdf/FileParserDataSource.php.

Change 

abstract public function __construct();

 

to

abstract public function __construct($filePath);

For more details follow this link Magento PHP 5.4 PDF invoice Zend error

 

---
Problem Solved Click Accept as Solution!:Magento Community India Forum