cancel
Showing results for 
Search instead for 
Did you mean: 

Imported Products showing up in categories view but not showing up under products

Imported Products showing up in categories view but not showing up under products

So the essentially what happened here was that I downloaded the product sheet from my wholesaler and set it up to match the required column headers that Magento needs in order to properly import products into the store (I used a .csv file, and made sure to set it to use UTF-8). I imported the products by going to System - Import/Export - Dataflow - Profiles, and selected the profile labeled Import All Products. I then set the profile to match the store that I wanted the products to appear in, and uploaded the .csv file into the importer and told it to run the profile in a separate window. It showed no errors during the import, and completed successfully. However, after the import was complete, and I had done the Re-Indexing, and Refreshed my Caches, none of the products were showing up under Catalog - Manage Products. I tried a few other things, but nothing worked, and then I finally decided to start adding some of the other categories into my store that I would later be using (I got frustrated trying to figure it out). It was when I was creating my first new sub-category that I realized that all of those products I had tried to import WERE showing up, but only under the Category Products tab of the sub-category product that I was creating. However, they still weren't showing up under the Catalog - Manage Products tab. I have tried looking into this issue on the Magento forms, and on Google, but I have yet to come up with anything relevant to my specific issue. I've included some images below that show what I am talking about.2018-01-17_1822.png

^ This image was taken from the Catalog - Manage Products tab, and shows some products that I had manually added to my website, but none of the imported products are showing up there. 

2018-01-17_1817.png

 ^ This image shows the products under the Category Products tab for the sub-category I had created. As you can see the imported products are showing up here, with much larger Product IDs to the left of the name, as compared to the ones I manually added.

 

I can't figure out whats going on here. I'm totally confused and not sure of what to do at this point. I really hope you guys can help me figure out what I did wrong, and how to fix it. (ignore the black boxes, I just wanted to hide sensitive information, such as the product names, and such)

1 REPLY

Re: Imported Products showing up in categories view but not showing up under products

Have you try reindexing? Just try reindex from backend,

Stores -> Index Management

Run indexer from above and clear cache and check.

If Issue Solved, Click Kudos/Accept As solutions.