cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 1.7.2 C.E. stucked on reindex

Magento 1.7.2 C.E. stucked on reindex

Hello,

 

After I changed a few images inside my magento folders, I cleaned cache and reindex everything through ssh.

 

Runned:

php indexer.php -reindexall

Everything runned "successfully".

 

After that, I did:

php indexer.php -status

 And everything is "pending".

 

Than I did one at the time:

php indexer.php -reindex catalog_product_attribute
php indexer.php -reindex catalog_product_price
php indexer.php -reindex catalog_url
php indexer.php -reindex catalog_product_flat
php indexer.php -reindex catalog_category_flat
php indexer.php -reindex catalog_category_product
php indexer.php -reindex catalogsearch_fulltext
php indexer.php -reindex cataloginventory_stock

After everything is "successfully", the status shows, "pending".

 

What am I doing wrong? Can it be a files permissions error?

 

What should be the correct file permissions?

 

Thanks in advance.

3 REPLIES

Re: Magento 1.7.2 C.E. stucked on reindex

Here are some notes on index management: http://docs.magento.com/m1/ce/user_guide/system-operations/index-management.html

 

While this explains it more from an admin perspective. "Pending" on command line status matches the "ready" state in admin which just means that there is no index process running and everything is fine.

 

Are there any other symptoms which suggests to you that the indexing process is stuck? Otherwise, I think everything is fine with indexes on your site. 

----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!

Re: Magento 1.7.2 C.E. stucked on reindex

First, thank you for your reply.

 

The main problem I'm facing is that the procuts inside categories are not showing up in the frontend.

 

In the backend, the configs are all the same.

Re: Magento 1.7.2 C.E. stucked on reindex

If there were no errors or warnings shown when reindexing on command line then indexing isn't the problem here. 

 

Here are some tips for getting products to show in categories: https://stackoverflow.com/a/2493774/1960680

----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!