cancel
Showing results for 
Search instead for 
Did you mean: 

Magento Customer Login, Register and Account pages not going under HTTPS

SOLVED

Magento Customer Login, Register and Account pages not going under HTTPS

Hi guys,

 

I've got a problem with securing the customer account pages on Magento CE 1.9.0.1. I've got an SSL installed on the server, 'Use Secure URLs in Frontend' is switched to 'Yes' and the checkout works under HTTPS and has the green lock icon next to the URL.

 

I've checked in 'app/code/core/Mage/Customer/etc/config.xml' and this is definitely including the XML for making anything under the '/customer/' URL to be HTTPS but whenever I try to register, login and even browse to my account pages it is all just unsecured.

 

I was wondering if anybody was able to give any advice/help or point me in the right direction for a fix?

4 REPLIES

Re: Magento Customer Login, Register and Account pages not going under HTTPS

Hi guys,

 

Anybody got any help or advice they could give on this? Really struggling to see why this is being a problem?

Re: Magento Customer Login, Register and Account pages not going under HTTPS

Hi callum_star. Did you end up finding the cause of this issue and/or a solution? We are currently stuck with exactly the same issue and have spent days trying to figure it out.

Re: Magento Customer Login, Register and Account pages not going under HTTPS

Hi @callum_star @brandsmith_nz

Have you tried setting both secure and unsecure url with https://?
You can find the settings there System / Configuration / Web / Secure / Base URL and there  System / Configuration / Web / Unsecure / Base URL

In both cases set:
Use Secure URLs in Frontend : Yes
Use Secure URLs in Admin: Yes

Was my answer helpful? You can accept it as a solution.
200+ professional extensions for M1 & M2 with free lifetime updates!

Re: Magento Customer Login, Register and Account pages not going under HTTPS

Hi @Amasty,

 

Yeah thats work now thanks very much, the client didn't want to do something like that originally which was why I was trying to find a separate way around it but they've relented now and the whole site now sits under HTTPS.

 

Thanks for the help!