cancel
Showing results for 
Search instead for 
Did you mean: 

Magento is returning “200 OK” status instead of “404 not found”.

SOLVED

Magento is returning “200 OK” status instead of “404 not found”.

Hello. I have installed Magento 1.7.0.2.

 

If I browse to a non-existent URL on my site, I receive a "200 OK" status from the server, despite the URL still being invalid and the 404 page still being presented.

 

>> culr - I www.shopmami.com//aa

HTTP/1.1 200 OK
Date: Mon, 09 Nov 2015 11:27:49 GMT
Server: Apache
X-Powered-By: PHP/5.2.17

 

Could you please help me?. 

 

3 REPLIES

Re: Magento is returning “200 OK” status instead of “404 not found”.

Hello juanrdosil,

 

Did you use any custom extension related to router? I think these extensions detect CMS no router, they also return 404 page not found, however, with 200 response code.

 

You should read more:

http://magento.stackexchange.com/questions/3223/status-200-for-404-not-found-cms-page

http://stackoverflow.com/questions/10817449/force-magento-no-route-to-return-status-301-instead-of-4...

Problem solved? Click Accept as Solution!

Re: Magento is returning “200 OK” status instead of “404 not found”.

The issue is in the template Blanco that i have installed. If i disable the template obtain the correct status 404 for the invalids urls.

 

Could anyone help me?

Re: Magento is returning “200 OK” status instead of “404 not found”.

When you buy a template , review it in depth. The visibility of the proyect has been dropping every week and we do not know why.

Now despite having the support I´m still hoping that the people of 8 Theme reply me and give me a solution.