cancel
Showing results for 
Search instead for 
Did you mean: 

Memory leaks

Memory leaks

Hi we are recently getting the following errors from our cron job....

 

Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 83 bytes) in /var/www/vhosts/ourdomainname.co.uk/htdocs/lib/Zend/Db/Statement/Pdo.php on line 291

 

So for testing purposes we Increased the memory limit from 1024mb to 1536mb and it leaked out of this too.

 

Fatal error: Allowed memory size of 1610612736 bytes exhausted (tried to allocate 80 bytes) in /var/www/vhosts/ourdomainname.co.uk/htdocs/lib/Zend/Db/Statement/Pdo.php on line 291

and

Fatal error: Allowed memory size of 1610612712 bytes exhausted (tried to allocate 56 bytes) in /var/www/vhosts/ourdomainname.co.uk/htdocs/lib/Varien/Object.php on line 270

 and

Fatal error: Allowed memory size of 1610612736 bytes exhausted (tried to allocate 120 bytes) in /var/www/vhosts/ourdomainname.co.uk/htdocs/lib/Varien/Data/Collection.php on line 562

 

Can anyone shed any light on these issues?

 

We are using Mangento 1.9.3.1

 Nginx and PHP-FPM

 

nginx.x86_64 1.8.1-1.el6.ngx @nginx

 

php55u.x86_64 5.5.31-1.ius.centos6 @ius
php55u-cli.x86_64 5.5.31-1.ius.centos6 @ius
php55u-common.x86_64 5.5.31-1.ius.centos6 @ius
php55u-devel.x86_64 5.5.31-1.ius.centos6 @ius
php55u-fpm.x86_64 5.5.31-1.ius.centos6 @ius
php55u-gd.x86_64 5.5.31-1.ius.centos6 @ius
php55u-ldap.x86_64 5.5.31-1.ius.centos6 @ius
php55u-mbstring.x86_64 5.5.31-1.ius.centos6 @ius
php55u-mcrypt.x86_64 5.5.31-1.ius.centos6 @ius
php55u-mysqlnd.x86_64 5.5.31-1.ius.centos6 @ius
php55u-odbc.x86_64 5.5.31-1.ius.centos6 @ius
php55u-opcache.x86_64 5.5.31-1.ius.centos6 @ius
php55u-pdo.x86_64 5.5.31-1.ius.centos6 @ius
php55u-pear.noarch 1:1.10.1-1.ius.centos6 @ius
php55u-pecl-jsonc.x86_64 1.3.9-1.ius.centos6 @ius
php55u-pecl-jsonc-devel.x86_64 1.3.9-1.ius.centos6 @ius
php55u-pgsql.x86_64 5.5.31-1.ius.centos6 @ius
php55u-process.x86_64 5.5.31-1.ius.centos6 @ius
php55u-soap.x86_64 5.5.31-1.ius.centos6 @ius
php55u-xml.x86_64

 

 

Yours hopfully

 

Tony

 

Tags (1)
2 REPLIES

Re: Memory leaks

Nobody got any ideas?

Re: Memory leaks

Well, I'd like to see full error stack as I don't relly know what is the root of the issue: we know which component complains but not why.

 

There's coud be any number of reasons why it happens. It could be for example a poorly implemented product import that instead of batching tries to load everything into memory at once.

Tanel Raja