cancel
Showing results for 
Search instead for 
Did you mean: 

Modules/Extensions installed via composer problem

Modules/Extensions installed via composer problem

I've installed locally on my computer Magento 1.9.3 and then via composer have installed a couple of extensions.
Modules/Extensions are Fontis Australia Post and Better404.


They seem to have installed OK ,I can see them in the folders and in admin/System/Advanced/Modules Output.
BUT I cannot see them anywhere else in admin to enable them.

 

Can any one advise on this

 

Thank you

5 REPLIES

Re: Modules/Extensions installed via composer problem

Hi @blabbs55,

 

If you check (on backend) into System - Configuration -> Advanced -> Advanced you'll see the full list of modules available on your Magento instance (available and installed).

Did you saw your modules there?

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Modules/Extensions installed via composer problem

Thanks for your reply Damian

 

Yes I can see them there

Re: Modules/Extensions installed via composer problem

Sorry. At some point my brain forgot the part when you said "I can see them in the folders and in admin/System/Advanced/Modules Output." (my bad)

 

In that case your modules are correctly installed.

 

If you aren't being able to see the modules on your backend, maybe you can run these checks:

 

  • Webserver error logs.
  • Activate the Magento logs and check if exception.log and system.log shows something related with those modules.
--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Modules/Extensions installed via composer problem

I've logged into my local MAMP Apache server logs and have a number of errors all with this same line

[Tue Nov 15 16:53:32 2016] [error] [client 127.0.0.1] client denied by server configuration: /Applications/MAMP/htdocs/Magento-1-9-3/site/app/etc/local.xml

File permission for local.xml is -rwxrwxrwx


Here is that Magento-1-9-3/site/app/etc/local.xml maybe there is an issue here?

 


<config>
<global>
<install>
<date><![CDATA[Thu, 03 Nov 2016 02:52:46 +0000]]></date>
</install>
<crypt>
<key><![CDATA[XXXXXXXXX]]></key>
</crypt>
<disable_local_modules>false</disable_local_modules>
<resources>
<db>
<table_prefix><![CDATA[]]></table_prefix>
</db>
<default_setup>
<connection>
<host><![CDATA[localhost]]></host>
<username><![CDATA[root]]></username>
<password><![CDATA[root]]></password>
<dbname><![CDATA[mag1_9_3]]></dbname>
<initStatements><![CDATA[SET NAMES utf8]]></initStatements>
<model><![CDATA[mysql4]]></model>
<type><![CDATA[pdo_mysql]]></type>
<pdoType><![CDATA[]]></pdoType>
<active>1</active>
</connection>
</default_setup>
</resources>
<session_save><![CDATA[files]]></session_save>
</global>
<admin>
<routers>
<adminhtml>
<args>
<frontName><![CDATA[admin]]></frontName>
</args>
</adminhtml>
</routers>
</admin>
</config>

Re: Modules/Extensions installed via composer problem

Hi @blabbs55,

 

That's not a real error.

Short version: the local.xml file could be accesible from the outside but the .htacess rule blocks the file to avoid being read.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"