cancel
Showing results for 
Search instead for 
Did you mean: 

Moved to new server / There has been an error processing your request

Moved to new server / There has been an error processing your request

HI guys

Please help me!! I've moved my magento installation to a new database and server and was sure i'd covered all the bases but i'm now getting this error on load.

 

I kept the new database password and username and db name the same so I thought it should have worked with no modification of local.xml

 

I think the old database was MySQL4 and this is MySQL5 Would that make any difference?

 

Thank you for looking...

 

In var/report I see:

 

 

a:4:{i:0;s:56:"Mage registry key "_resource_helper/core" already exists";i:1;s:1774:"#0 /var/www/vhosts/localhost.localdomain/httpdocs/gep/store/app/Mage.php(223): Mage::throwException('Mage registry k...')
#1 /var/www/vhosts/localhost.localdomain/httpdocs/gep/store/app/Mage.php(563): Mage::register('_resource_helpe...', false)
#2 /var/www/vhosts/localhost.localdomain/httpdocs/gep/store/app/code/core/Mage/Core/Model/Resource/Db/Collection/Abstract.php(534): Mage::getResourceHelper('core')
#3 /var/www/vhosts/localhost.localdomain/httpdocs/gep/store/app/code/core/Mage/Core/Model/Resource/Db/Collection/Abstract.php(520): Mage_Core_Model_Resource_Db_Collection_Abstract->_prepareSelect(Object(Varien_Db_Select))
#4 /var/www/vhosts/localhost.localdomain/httpdocs/gep/store/lib/Varien/Data/Collection/Db.php(572): Mage_Core_Model_Resource_Db_Collection_Abstract->getData()
#5 /var/www/vhosts/localhost.localdomain/httpdocs/gep/store/app/code/core/Mage/Core/Model/Resource/Website/Collection.php(137): Varien_Data_Collection_Db->load(false, false)
#6 /var/www/vhosts/localhost.localdomain/httpdocs/gep/store/lib/Varien/Data/Collection.php(729): Mage_Core_Model_Resource_Website_Collection->load()
#7 /var/www/vhosts/localhost.localdomain/httpdocs/gep/store/app/code/core/Mage/Core/Model/App.php(634): Varien_Data_Collection->getItemById('0')
#8 /var/www/vhosts/localhost.localdomain/httpdocs/gep/store/app/code/core/Mage/Core/Model/App.php(466): Mage_Core_Model_App->_initStores()
#9 /var/www/vhosts/localhost.localdomain/httpdocs/gep/store/app/code/core/Mage/Core/Model/App.php(349): Mage_Core_Model_App->_initCurrentStore('', 'store')
#10 /var/www/vhosts/localhost.localdomain/httpdocs/gep/store/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#11 /var/www/vhosts/localhost.localdomain/httpdocs/gep/store/index.php(87): Mage::run('', 'store')
#12 {main}";s:3:"url";s:56:"/store/index.php/cd-s/southern-empire/images/favicon.ico";s:11:"script_name";s:16:"/store/index.php";}

3 REPLIES

Re: Moved to new server / There has been an error processing your request

Hello @deniewibly,

 

 disabled compile and cache flush then check it.

 

Re: Moved to new server / There has been an error processing your request

Hi. Thank you for replying. How do I disable compile?

 

Thanks


Dene

Re: Moved to new server / There has been an error processing your request

I think i have compile disabled in config.php?

 

#define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');
#define('COMPILER_COLLECT_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'stat');