cancel
Showing results for 
Search instead for 
Did you mean: 

New categories not showing live in front-end

New categories not showing live in front-end

I've recently taken on a pre-built magento store, with no handover. 

 

I need to add a new sub-category, which I've done many times in other magento stores. Created a sub-category - is active. When I check the front-end I see a 404. I have checked all settings are the same as the other categories on the site, but it still shows a 404. 

 

Any ideas? 

Tags (2)
8 REPLIES

Re: New categories not showing live in front-end

Hi @sally_hayler

 

could you please confirm that you have created this category under the Default category of magento ?

 

Also have you check in url rewrite section , where your category is showing or not ?

 

if issue solved,Click Kudos & Accept as Solution

Re: New categories not showing live in front-end

Hi @ManthanDave

 

Yes, I have my default category - then a few other sub categories and I've created it under one of those...

There are lots of other categories within it already that had been set up before I took it over, it's sitting in the right place, is live but when the URL is entered it's a 404. 

I tried re-activating an old inactive category within the same sub-category which worked, thought I could just re-work that, so changed the title (that worked), changed the URL - it then goes to a 404. 

 

Sally 

 

Re: New categories not showing live in front-end

Hi @sally_hayler

 

As you have changed the title of new category , you also need to change it url-key .

 

As currently url-key will be same like old one  but it required unique, so kindly change its url-key and then save category again !!

 

then check at frontend.

if issue solved,Click Kudos & Accept as Solution

Re: New categories not showing live in front-end

Hi

 

Yes it's under the default category... see image to show what I mean... The new category I created is the third one down (beiginning with an A)... Capture.PNG

 

URL re-write like this... Capture2.PNG as it is on all other categories. 

Re: New categories not showing live in front-end

Hi @ManthanDave

 

Yes that's what I did - to test if I could re-work an old category that I know works. But when I changed the URL key to what I wanted it to be, it changed into a 404. 

 

I just want to create a new category, something I've done so many times before, but it just is a 404. 

Re: New categories not showing live in front-end

@ManthanDave

 

We are integrated with linnworks could that be causing a problem. I've not had much experience with Linnworks. 

 

Re: New categories not showing live in front-end

@sally_hayler

 

Actually , your screenshot seems not visible to us, so its difficult to troubleshoot your issue.

 

Linnworks might cause the issue for the same.

if issue solved,Click Kudos & Accept as Solution

Re: New categories not showing live in front-end

Guess I'll try to find the answer elsewhere.

Categories Are for example 

 

-Root Category 

      -Sub Category 1

             -Sub Category 1.1 (going to 404)

             -Sub Category 1.2 (working)

             -Sub Category 1.3 (working)

             -Sub Category 1.4 (working)

      -Sub Category 2

             -Sub Category 2.1 (working)

             -Sub Category 2.2 (working)

             -Sub Category 2.3 (working)

             -Sub Category 2.4 (working)