cancel
Showing results for 
Search instead for 
Did you mean: 

New module in ADMIN are showing A 404 page

SOLVED

New module in ADMIN are showing A 404 page

Since we have upgraded the magento 1.9.2.2 and add the module : https://bitbucket.org/magebit/whitelister/downloads   By magebit.

 

After installing new addons , flushing the cache , loging into the admin I still have some modules that show a 404 page. Do you know how I can solve these error ?

 

9 REPLIES

Re: New module in ADMIN are showing A 404 page

Hello xavkick,

 

You try to add translate="title" and module="magebit_whitelister" in config.xml the second ACL menu: line 91 -99

 

                            <children>
                                <config>
                                    <children>
                                        <magebit_whitelister translate="title" module="magebit_whitelister">
                                            <title>Magebit - Whitelister</title>
                                        </magebit_whitelister>
                                    </children>
                                </config>
                            </children>

Log out and log in again.

 

 

Problem solved? Click Accept as Solution!

Re: New module in ADMIN are showing A 404 page

 thank for your answer but the Whitelister add-ons is working.. it's other third party modules  I have 404 error page..  

And in the config.xml line between 91-99 are 

 

<core>
<class>Mage_Core_Model</class>
<resourceModel>core_resource</resourceModel>
</core>
<core_resource>
<class>Mage_Core_Model_Resource</class>
<deprecatedNode>core_mysql4</deprecatedNode>
<entities>
<config_data>

Re: New module in ADMIN are showing A 404 page

Well, I think I know where is the issue .

 

My website admin is   http://mywebsite.com/admin

and when I'm logging i have http://mywebsite.com/admin/admin

can you tell me how to change it please ?

Re: New module in ADMIN are showing A 404 page

Hello,

 

The Whitelister is working now?

 

Actually, I find ACL in config.xml or adminhtml.xml under etc folder. You should find the <acl> node in this files.

Problem solved? Click Accept as Solution!

Re: New module in ADMIN are showing A 404 page

Yes the whitelister is working now  but please read my previous post about my admin adress

Re: New module in ADMIN are showing A 404 page

Hello

 

You try this solution here: http://magento.stackexchange.com/questions/40620/correct-way-to-change-the-magento-1-9-admin-url

Problem solved? Click Accept as Solution!

Re: New module in ADMIN are showing A 404 page

Yes But if it change :

 

<admin>
        <routers>
            <adminhtml>
                <args>
                    <frontName><![CDATA[admin]]></frontName>
                </args>
            </adminhtml>
        </routers>
    </admin>

to 

<admin>
        <routers>
            <adminhtml>
                <args>
                    <frontName><![CDATA[hello]]></frontName>
                </args>
            </adminhtml>
        </routers>
    </admin>

I still have admin in the admin address

http://www.mywebsite.com/index.php/admin/hello...

Do you know where I can find why admin is still in the link ?

 

Re: New module in ADMIN are showing A 404 page

I just found the issue.

because the option

- Add Store Code to Urls

 was enable.

Thank you for your help

xavier

 

Re: New module in ADMIN are showing A 404 page

After install module / Extension please log out from admin and again login it will solve. 

in my case i have tried it and it was working for me.