cancel
Showing results for 
Search instead for 
Did you mean: 

No CSS loaded in frontend

No CSS loaded in frontend

Hi!

This problem occurred out of nowhere. No css is loaded in frontend, regardless of which store view that I choose, and it doesn't help changing to a different theme. It's the same on all pages, not just the front page.

 

I emptied the cache, so that was not the problem.

 

One thing I haven't seen before is that the alternate logo text on the front page shows twice. Don't know if it's related to the problem..

 

When I check the console, it says:

"Varien is not defined"

"JQuery is not defined"

"Varienform is not defined"

"Varienform is not defined"

 

and on style editor, it says that this page have no stylesheet.

 

I'm a beginner so I have no idea what the problem is or what may have caused it, but would really appreciate any suggestions!

 

 

4 REPLIES

Re: No CSS loaded in frontend

Will you be able to post the link to your website here so that we can see what is going on? 

 

Did you do anything at all before the issue happened? Examples include any upgrades, extensions or themes installation, running Magento backup, etc. 

James Lee | Moderator • Magento Master
See My Recommended Magento Hosting & Security Tips

Re: No CSS loaded in frontend

Right now I'm learning Magento, so it's on localhost.

 

I was just going through an excercise that I had done earlier, that involved an observer class. It belonged to a module which contained some test exercises. There were some problems with the observer class, and there is a log file in magento/var/report which says:

Mage registry key "_singleton/test01/observer" already exists";i:1;s:5562:"

 

When the css problem ocurred, I thought that by deactivating the test module, everything would work, but it didn't help. That was surprising because I can't remember doing any changes in my main module.

 

Another thing which I did recently is a manuall install of a theme. I got it to work, but then decided to use the rwd theme. The problem occurred after having used the rwd theme for some time.

 

Maybe I have to reinstall everything..

Re: No CSS loaded in frontend

Yeah since you are testing things out, it'll be easier to reinstall your store. Smiley Wink

James Lee | Moderator • Magento Master
See My Recommended Magento Hosting & Security Tips

Re: No CSS loaded in frontend

Yup, I did that.

 

The problem may have had to do with localhost in some way. I couldn't write "localhost" when installing, so I wrote "127.0.0.1". Later I got help from a guy who knows Magento , with getting Google analytics to work with Magento on localhost, and briefly the CSS-problem occurred again, but he seemed to solve it by going into the database, "core_config_data" and editing the url on "web/unsecure/base_url" and and "base_url" and put in "localhost" there (maybe it was set to 127.0.0.1" ). And then it worked. Maybe reinstalling wamp would had solved my problem the first time, I don't know.