cancel
Showing results for 
Search instead for 
Did you mean: 

Order Missing Invoice

Order Missing Invoice

We are running Magento 1.9.3.3 on a Linux CENTOS 7.3 x86_64 standard – host  cPanel & WHM 64.0 (build 36); We have been running since December 24th 2016.  We are very happy for the most part.  Main issues are extension conflicts and slightly unstable Magento upgrades using Softaculous.  I have a strange situation involving an order.  The order looks normal in the Admin panel except when I go into Order view and view the Invoices.  It shows no invoices, status of the order is Processing.    Order appears to have been processed normally meaning the Customer received an Order Confirmation email, the payment was process successfully in Authorize.net, payment captured, and the Comments History shows an invoice was created at the time of the order.  When I inspect the database using phpMyadmin, I see the invoice record in the sales_flat_invoice table.  Do you know why the invoice would exist in the table and not display under Invoices under Sales/Orders?

UPDATE: Upon further inspection, I found that the probable cause for the invoice not being displayed is because the record is missing from the sales_flat_invoice_grid.  If that is true, is there a way to repair this in Magento? 

UPDATE: Two weeks and no one has replied to this post.  Yesterday, I found 5 orders with this condition. Am I the only one experiencing this problem?

Tags (2)
2 REPLIES

Re: Order Missing Invoice

We are experiencing this same issue.

Re: Order Missing Invoice

The problem is intermittent for me.  Since July 25th, out of 81 orders, 7 have this condition.  I recently upgraded the Magento 1.9.3.4 and still the problem persist.  The only way I can clear the order is to marked it Shipped.  The Invoice button on the edit order page does not appear.  The invoice to show the order is paid is there, but Magento does not have the record in the Grid so I assume Magento considers it a "Quote" and does not know to treat it as an "Order".  Does anyone know of a way to debug this problem by tracing the function that creates the order at checkout?

It appears we are not going to get any help on this blog.  I plan to post the same problem on Magento Stack Exchange later today.