cancel
Showing results for 
Search instead for 
Did you mean: 

Product Image Uploader broken in 1.9.3

Product Image Uploader broken in 1.9.3

Hi.

 

We have an error when we upload a image to magento 1.9.3.7 vía the new JS uploader, the image uploads correctly to the server but dont show in the product image grid to select then.

 

We revised the permissions folder (0777) and the file lib/Varien/File/Uploader.php, everthing is correct.

 

We Install a extension that overrides the old flash system. Not working.

 

Checking the code in an older version 1.9.2.4, the input hidden id "media_gallery_content_save" updates whit the new image when upload a image via old flash system, but in the new system this input doesnt update with the new data.

 

Somebody have the same issue. Anybody knows if this is a bug in new Magento versions after 1.9.3.2?. There is a solution?.

 

The last thing we want to do is to disable one by one the installed extensions to see if there is a conflict with one of them.

 

Thanks.

 

 

10 REPLIES

Re: Product Image Uploader broken in 1.9.3

Are there any errors in the developer console on the browser to suggest any missing files or javascript errors perhaps?

 

What are the permissions on the image folder?

----
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution" as appropriate. Thanks!

Re: Product Image Uploader broken in 1.9.3

Hi, Tom.

 

In the developer tools in the section console and metwork there is no errors and in the network section the response of the server for an upload image is this:

 

Spectacle.n16667.pngSpectacle.w16667.png

 

 the response data is:

{"name":"Screenshot_20170529_185359.png","type":"image\/png","tmp_name":"\/tmp\/phpXE8bB7","error":0,"size":15122,"path":"\/var\/www\/vhosts\/juguetronica.com\/httpdocs\/media\/tmp\/catalog\/product","file":"\/s\/c\/screenshot_20170529_185359_6.png.tmp","url":"https:\/\/cdn-static1.juguetronica.com\/media\/tmp\/catalog\/product\/s\/c\/screenshot_20170529_185359_6.png","cookie":{"name":"adminhtml","value":"b730c660f4158a6bfe6fd2bf2f8263e2","lifetime":259200,"path":"\/","domain":"www.juguetronica.com"}}

 

thanks.

 

Re: Product Image Uploader broken in 1.9.3

Hi @txantxo1,

 

With the SUPEE-8788 patch there where some issues (not for everybody). You maybe could take a moment to check this links:

 

 

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Product Image Uploader broken in 1.9.3

Also you can check this thread: https://community.magento.com/t5/Security-Patches/SUPEE-8788-Solutions-to-Different-Problems/m-p/525...

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Product Image Uploader broken in 1.9.3

Hi Damian.

 

After checking the links and doing some of the solutions, the problem is not solved.

 

We disable all the third party extensions, and the problem is there, reload all the files in the folder skin/adminhtml and app/design/adminhtml from the magento 1.9.3.7 zip archive, and the problem still there. Update older versions of plugins and they dont resolve the error.

 

Uploading images via wysiwyg and they appear in the list of uploaded imagens to use them. We detect there is another problem, the problem is we can select the image type(base, small, thumb) from the image grid in product. In the database store fine but the grid cant load the selected images in magento backend.

 

The server response to upload images is 200 and the files exists in the folder and is visible and accesible, in the console there is no errors.

 

We are using a CDN to store the scripts and media, but change this to the storage in our server and the problem is the same.

 

Attach some screenshots.

 

Spectacle.i18181.pngImages are not selectedSpectacle.Z18181.pngSelected images and click on save and return to the first image

 

 

Process to upload a image:

Spectacle.V18181.pngSpectacle.m18181.pngSpectacle.d18181.pngSpectacle.Q18181.png

Re: Product Image Uploader broken in 1.9.3

I have the same problem. 

Somebody knows a solution?

Re: Product Image Uploader broken in 1.9.3

Hello,

 

If you applied patch or upgrade magento then please check with fresh window.

 

It will ask permission for flash add on, make sure you have flash add on for same.

 

If it will help you then mark as solution.

Re: Product Image Uploader broken in 1.9.3

Hi.

What do you mean by "fresh window"?

The gallery images uploader does not use Flash since the last patches...

Re: Product Image Uploader broken in 1.9.3

Hello,

 

Fresh window means incognito mode .