cancel
Showing results for 
Search instead for 
Did you mean: 

Product Image Uploader issue

Product Image Uploader issue

If anyone has any ideas on this I would be extremely grateful. 

 

The product image upload system seems to be broken on the site I'm working on. I've tried following all of the advice given on this page, but it's still not working. I've also checked the folder permissions, and all is fine there.

 

The site has the SUPEE-8788 patch installed, and I suspect something is conflicting with the new non-flash uploader, but I can't figure out what. 

 

I'm presented with the Browse Files... and Upload Files buttons. If I click on the Browse Files button, I am able to select an image on my computer, and the upload bar appears on the page. The upload appears to complete and then simply disappears. 

 

In the Console, I can seen an error that states: 

ee4950b….js:22824 Uncaught TypeError: Cannot read property 'removeFile' of undefined

...which links to the Product.Gallery.prototype.handleUploadComplete section of the core js file - specifically, the line:

this.uploader.removeFile(item.id);

Having now spent the best part of two days scratching my head, I'm really hoping that someone here has a clue what this means... Many thanks in advance

2 REPLIES

Re: Product Image Uploader issue

Hi @titus,

 


What is the level of customization of your Magento store?

Even though patches are designed to work on all the supported Magento versions, there are times when over-customized stores may have problems with the patches.

If my answer was useful, please give "Kudos" to this post.
If my answer helps you to resolve the problem, click on "Accept as Solution".

Re: Product Image Uploader issue

Hi @Gabriel Guarino

Thank you for getting back to me. I fear the site has been customised quite a bit. Unfortunately, I wasn't the original developer, but have been asked to help 'maintain' the site in question (eclipsefurniture.co.uk). I'm afraid I'm not really a Magento person, so am a little out of my depth on this one. I was able to install updates and follow advice online regarding security updates, clearing cache etc., but have become stuck with this issue.  I was hoping someone else might have come across a similar issue and might be able to point out where the issue might be... Thank you anyway...