cancel
Showing results for 
Search instead for 
Did you mean: 

Product thumbnail when clicked will say the requested content cannot be loaded.

Product thumbnail when clicked will say the requested content cannot be loaded.

Hello everyone,

 

Some of the products in my site has a missing image, But when I try to check the specific missing product in the backend of my magento. The image is there but when it comes to frontend it is missing. But the other products is working fine.

 

Thank you,

6 REPLIES

Re: Product thumbnail when clicked will say the requested content cannot be loaded.

Hello MazeStricks,

 

You try to clear Magento Cache! If still not working, please capture screen shots or give us your website link.

Problem solved? Click Accept as Solution!

Re: Product thumbnail when clicked will say the requested content cannot be loaded.

Hello @MazeStricks,

 

Did you just import images from csv? If not then clearing cache as @MrKhoa99 suggested would solve problem. Or you can go directly to media/catalog/product and detele cache folder.

In case you just imported from csv, then you should take a look at your csv file, comepare what difference between those displaying fine with those're not.

I encoutered this problem once, at that time my last choice was to dump all the image info of 2 different products to see what the other is missing.

 

Best Regards,

Jimmy.

Re: Product thumbnail when clicked will say the requested content cannot be loaded.

@maxid192 and @MrKhoa99

 

Thank you for your response guys. My problem got even bigger because the clients cannot recieve any leads from any forms in the site. I cannot also reindex the catalog_url_rewrite and when I click some of the products, It will lead to 404 not found. Here's a sample link : http://www.eeclink.com/stainless-steel-smokehouse-screens-16490 , And here is the sample link also of the product without image : http://www.eeclink.com/alkar-linear-oven-the-cyclone-series . I have tried what you guys advice me to do but still no luck the problem is still there.

 

Thank you,

MazeStricks

Re: Product thumbnail when clicked will say the requested content cannot be loaded.

Hello MrKhoa99

 

I followed your instructions to take a look at the csv file. but the csv file that was uploaded to that site is ok. It seems that the problem is on the reindexing thing. The rest can be reindexed except for the "Catalog URL Rewrites". I've done already shell reindexing but nothing works.

 

Thank you,

MazeStricks

Re: Product thumbnail when clicked will say the requested content cannot be loaded.

Hello MazeStricks,

 

-For image not loading: you should try to delete cache folder under /media/catalog/product/

-For re-indexing problem: you should google. I suggest you: http://www.milessebesta.com/web-design/catalog_url_rewrites_error_solved/ . The "bad" solution, you truncate core_url_rewrite and then re-index your database again.

Problem solved? Click Accept as Solution!

Re: Product thumbnail when clicked will say the requested content cannot be loaded.

Hello MrKhoa99

 

I have already deleted the cache folder under /media/catalog/product/ but still the problem is there. I've been googling for over an hour but still, I could not manage to fix this problem. In terms of reindexing, I tried reindexing the catalog url rewrite using shell but this is the error mesage that will display after hitting the command.

 

 

eeclink3@serv01 [~/public_html/shell]# php5 indexer.php reindexall
Content-type: text/html

<br />
<b>Parse error</b>: parse error, unexpected T_ARRAY, expecting '&' or T_VARIABLE in <b>/home/eeclink3/public_html/app/Mage.php</b> on line <b>445</b><br />

 

 

Thank you,
MazeStricks