Showing results for 
Search instead for 
Did you mean: 

SOAP isn't working through SSL

SOAP isn't working through SSL

I am experiencing a very annoying problem. The Magento shop on one of our servers isn't loading SOAP correctly over SSL. 


When trying to load everything works fine (I get this Access denied message). 

When trying to load through SSL I get this message that Magento isn't able to load the WSDL: 


This XML file does not appear to have any style information associated with it. The document tree is shown below.
<SOAP-ENV:Envelope xmlns:SOAP-ENV="">
SOAP-ERROR: Parsing WSDL: Couldn't load from '' : failed to load external entity ""


We tested a lot and made sure that:

- the exact same SOAP POST of this installation is working on another server

- another fresh Magento installation on the same server is also correctly loading over http:// but not over https://

- we get the same error when using curl via ssh on the server itself.



Re: SOAP isn't working through SSL

Hi @Ericovk


If you are using Cloudflare, please refer this link Magento soap api not working on secure url it may help you.

Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: SOAP isn't working through SSL



I am not using cloudflare. The website is hosted on its own VPS.

Re: SOAP isn't working through SSL

i have same problem here, cant find help.

Re: SOAP isn't working through SSL

We never found the cause of the problem. Probably it was somewhere in the system settings. We migrated the installation to get it working.