cancel
Showing results for 
Search instead for 
Did you mean: 

Sales emails not working since 365 switch

SOLVED

Sales emails not working since 365 switch

Greetings,

Let me start off by saying I'm not a web guy by any means. I actually do general IT and email support for my company, and have been assigned to figure this issue out, so please be patient with me!

 

We switched to exchange online with 365 a few months ago, and I was just informed that the sales emails are not going to who they need to go to. The web guy says it's probably an issue with exchange online. So I'm trying to understand how Magento sends out the emails to the users designated within the system. Is it the Magento system sending it out to the email designated and all the smtp stuff is in the background and I can't modify? Are their smtp settings somewhere and I need to point it to the new server to authenticate to in order to send the mail?

 

According to my web guy, you just put in the emails you want Magento to send to, and it does it. But he couldn't tell me what domain it was sending the emails from so I could even block spam filter.

 

I hope this isn't a completely incoherent post. I would appreciate some help to get this resolved, as apparently this hasn't been working for like 4 months now, and people are quite eager to get this fixed.

 

Magento version 1.9.3.8

3 REPLIES

Re: Sales emails not working since 365 switch

Magento usually uses PHP Mail unless you have a SMTP extension installed. 

 

Before going the SMTP route (I don't believe it's due to authentication issue), is the Magento domain and the email domain the same domain name? 

 

Your server may be attempting to deliver the email locally so you may want to check the server's email routing for the local domain name. 

James Lee | Moderator • Magento Master
See My Recommended Magento Hosting & Security Tips

Re: Sales emails not working since 365 switch

Thanks for the reply!

Good information here. The domain and Magento are sharing the same name. When you say the server may be attempting to deliver the email locally, are you referring to the Magento side of things? Is there a way to lookup/change these settings from within Magento?

 

Before we switched to 365 email, mail was free with the domain name and configured in cpanel, so it makes sense Magento is pointing to that, which has no MX records pointing to it for mailflow anymore. I'm just not sure where in Cpanel or Magento this option might be haha.

 

Again, sorry for my ignorance. I'm a Sys Admin, so all of this is a bit beyond me. 

Re: Sales emails not working since 365 switch

This definitely sounds more like a server problem than a Magento problem. 

 

Try checking your cPanel > Mail Routing and make sure that it is set to Remote Mail Exchanger.

 

If it is set to Auto or Local, your server will attempt to deliver all emails directed to your own domain locally, that means the emails will end up in the inbox of your local email account instead of 365. 

James Lee | Moderator • Magento Master
See My Recommended Magento Hosting & Security Tips