cancel
Showing results for 
Search instead for 
Did you mean: 

Static block shortcodes not working - 1.9.2.2

SOLVED

Static block shortcodes not working - 1.9.2.2

So i've updated our website from 1.9.2.1 to 1.9.2.2 and ALL static blocks added in a form of "shortcodes" are not working any more on any places. Widgets are still working, but static blocks shortcodes on pages, m2epro descriptions are not working. Any help guys? Thanks!

 

Shortcode example:

{{block type="cms/block" block_id="footer_links"}}

 

 

EDIT: Forgot to mention that i've tried using a fresh install of 1.9.2.2 and static block shortcodes is not working out of the box

12 REPLIES

Re: Static block shortcodes not working - 1.9.2.2

MAGENTO_ROOT/var/log/system.log shows this error also:

ERR (3): Notice: Undefined variable: block  in /app/code/core/Mage/Core/Model/Email/Template/Filter.php on line 187

Re: Static block shortcodes not working - 1.9.2.2

You probably need to add the block types you're using to the allowed blocks through System => Permissions => Blocks:

 

More information:

 

http://magento.stackexchange.com/questions/87466/appsec-1057-how-to-add-variables-or-blocks-to-the-w...

 

Did I help you solve your problem? Click Accept as Solution!
DudeSquare Web Development

Re: Static block shortcodes not working - 1.9.2.2

I had the same issue with using shortcakes after upgrading to 1.9.2.2. Static blocks on a CMS page were no longer showing.

 

I updated permissions the blocks thro' Permissions > Blocks w/o any success.

 

However, re-adding the blocks to the CMS page using the Insert Widget method worked for me. So I now have the following:

<div class="offers">
{{widget type="cms/widget_block" template="cms/widget/static_block/default.phtml" block_id="18"}}
</div>

 

Cheers,

 

ps - i'm a little confused about the role of Permissions > Blocks. For example, I'm using static blocks in phtml files (using short code) and these are displaying correctly. So, presumably Permissions only applies to CMS pages?

Tags (1)

Re: Static block shortcodes not working - 1.9.2.2

dudesjoerd suggested a working solution for me. I guess they should have just added "cms/block" by default on the block permissions. Or is it a bad idea now?

Re: Static block shortcodes not working - 1.9.2.2

Adding the block to System > Permissions > Blocks resolved it for me as well.

Re: Static block shortcodes not working - 1.9.2.2

New feature...Don't know why, but this is a new feature....

Re: Static block shortcodes not working - 1.9.2.2

You have to add Block Class Name similar to the one you use for type in System > Permissions > Blocks.

Not Block ID or Block Name!

Re: Static block shortcodes not working - 1.9.2.2

Permissions did work well for me

Re: Static block shortcodes not working - 1.9.2.2

Given the confusion caused by this upgrade, I wrote a little blog post to explain what causes this issue and how to fix it. I'm new to this, so any feedback is appreciated.

Did I help you solve your problem? Click Accept as Solution!
DudeSquare Web Development