cancel
Showing results for 
Search instead for 
Did you mean: 

admin menu not working

admin menu not working

In admin module apart from Dashboard all other modules are not clickable. I cannot access the other modules.

18 REPLIES

Re: admin menu not working

Hi @hm2011

Please check browser console for nay possible javascript errors.If you see the errors in the console try to fix those issues.

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: admin menu not working

 If issue with admin drop down menu
Browser console also shows = ReferenceError: require is not defined

fix:
Switch to the developer mode, and the static content will be deployed automatically .
uncomment below line  inside .htaccess of  root folder
  SetEnv MAGE_MODE developer

Re: admin menu not working

Me too had this issue, but i have resolved that issue.  That is mainly happened because of merging JS files have enabled in 

system configuration.

 

So you need to disable them or by database you can find the "core_config_data", and find the key : dev/js/merge_files 

then change the value from 1 to 0. That's it.

Re: admin menu not working

In the panel all the menu url has a # at the end of them and i can't have access to any menu besides the dashboard,

I went into my database and found the table core_config_data, but there is no key   dev/js/merge_files to disable, is there any other solutions?

Re: admin menu not working

Hi,

 

I am facing the same issue. Since my admin panel isn't working at all how can I disable js merge?

Re: admin menu not working

Hey, I'm facing the same issue...

all solutions I found:
1. creating the "dev/js/merge_files" and "dev/css/merge_css_files" with values 0 in the core_config_data table

2. clearing the cach folder

3. changing the permissions of the "app/etc", "pub" and "var" folders

dosn't solve the problem

Re: admin menu not working

Hi, I had the same issue. but solved by following this link

 

  1. Remove everything, except .htaccess file from pub/static folder
  2. Open up app/etc/di.xml find the path “Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink” and replace to “Magento\Framework\App\View\Asset\MaterializationStrategy\Copy”

http://www.dckap.com/blog/magento-2-admin-links-not-working-in-windows/

Tags (1)

Re: admin menu not working

Hey everyone!

 

If I'm only following step 2 of linu's solution:

 

2. Open up app/etc/di.xml find the path “Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink” and replace to “Magento\Framework\App\View\Asset\MaterializationStrategy\Copy”

 

All the pictures in the Admin Menue are now where they have to be and all the links are working fine! I'm not surre if step 1 is necessery.
Maybe someone else can test it and please reply if step 1 is importend ore not (in the comments under the link that linu has postet there are some people how get issues with this two steps....maybe its because step 1 is deleating something thats needed ... I realy don't know)

If I find any reason why step 1 is realy importent than I will reply here...I'm know testing if everything is working

Big Thanks to linu!!!

 

Re: admin menu not working

after so much searches i found this very usefull thnaks