cancel
Showing results for 
Search instead for 
Did you mean: 

banner sliders stopped working - .js issue?

banner sliders stopped working - .js issue?

hi all....

The banner sliders on two of my websites have recently stopped working.

http://www.testmate.co.uk/
http://www.stroma-store.com/

I can't pinpoint the issue and suspect that some .js code is incorrect.

It may be that a recent .js or .css update elsewhere in the installation is causing the problem, but I again, I can't pinpoint it.

Any help would be very much appreciated.

Thank you in advance

Andy

4 REPLIES

Re: banner sliders stopped working - .js issue?

@Andy_Acute, Its issue of your cycle js,camera js and superfish js not properly load in your store. So you have to first give proper path for your js or may be confict with jquery.

 

Show your js defination in your file where you have define your js.

 

Thanks.

Answer Helpful, Click Kudos for post.

 

If Issue Solved, Click Kudos/Accept As solutions.

Re: banner sliders stopped working - .js issue?

Thank you Rakesh Jesadiya, but I still have no idea how to fix it.

Could you explain again please??

Thank you

Re: banner sliders stopped working - .js issue?

When you check in console of your site, http://www.testmate.co.uk/

 

slideshow.js:33 Uncaught TypeError: $j(...).cycle is not a function

You have js error reside in console so first you have to resolve this js error from console, Once error is resolved your slider will works well.

 

For second site,

http://www.stroma-store.com/

Superfish and camera js error are available,

Uncaught TypeError: jQuery(...).superfish is not a function
camera.js:747 Uncaught TypeError: $(...).live is not a function

So first you have to resolve this error from code level, where you have defined your code you have to debug for this error and once console error gone your slider is working.

 

If answer helpful, click Kudo and Accept as answer.

 

 

If Issue Solved, Click Kudos/Accept As solutions.

Re: banner sliders stopped working - .js issue?

so this is what I've done.....

I renamed 'jquery.min_.js' in the root js/jquery folder and all is working correctly again.

This can't be a permanent fix, so how do I fix the 'real' issue?

Many Thanks

Andy