cancel
Showing results for 
Search instead for 
Did you mean: 

can´t get to my products anymore

can´t get to my products anymore

Hi everyone,

 

has anyone seen this before? and maybe an idea how to solve it?

Source model "magesetup/source_revocationProductType" not found for attribute "revocation_product_type"

 

I was running a little shop for several years on version 1.7.0.2 until it got hacked and the installation went corrupt.

I couldn´t log into the admin panel anymore and after a while the whole shop went down. So I figured maybe a new installation would let me get back in when I connect the new installation to the old database. So I tried with a version 1.9.  at that time but couldn´t get back to my products. Now I also tried a new installation (backup) of 1.7.0.2

When I enter the shop now, I can see everything on there like the menus or the catalog list but as soon as I cklick on a product to open it I get a "page not found 404"

When I try to enter through the admin panel, which works again, and go to 'Catalog' -> 'Manage Products' I get the list of available products but again, I´m not able to open one of the items. Instead I get the following message:

 

There has been an error processing your request
Exception printing is disabled by default for security reasons.
Error log record number: 71970125

 

When I try to export the products through 'System' -> 'Import/Export' -> 'Export'

the system hangs with an error message saying:

Source model "magesetup/source_revocationProductType" not found for attribute "revocation_product_type"

 

 

Could there be any way to fix this somehow you think?

 

thanks for reading

Thomas

2 REPLIES

Re: can´t get to my products anymore

You can try to use a copy of the old database and install a new magento store over the existing database. That's what I've done so far and I could continue using the existing products. Be sure, that the database isn't corrupt.

Download the latest version of magento and start the setup routine. When Magento asks for the access data of your database, use the acess data of the "old" database. Magento will automatically upgrade your Database to Magento 1.7.

After that you have to install your theme and all the extensions you used in the old shop. Be sure, they are working on magento 1.7. And you have to copy the media folder, to use all images of products and categories.

This may help you: http://indieswebs.com/blog/upgrade-to-latest-magento-using-fresh-install-technique/ http://neoshops.de/2013/08/03/how-to-upgrade-magento-using-old-database/

OpenSource Expert | OpenSource Technologies | www.opensourcetechnologies.com
Magento plugins released: http://www.opensourcetechnologies.com/product/product-category/magento-extensions

Re: can´t get to my products anymore

thanks for your help, I´ll give that a try,

havent´t actually tried a clean reinstall using the setup routine, just the reinstall through my providers preconfigured 'oneclickinstall' thingy

 

cheers

Thomas