cancel
Showing results for 
Search instead for 
Did you mean: 

"There has been an error processing your request" problem. Please help.

"There has been an error processing your request" problem. Please help.

Hello, I am using magento 1.9 and today i just edited my Local.xml in app/etc/local.xml. I just added some lines like 

<cache>
<backend><![CDATA[memcached]]></backend>
<fast_backend><![CDATA[memcached]]></fast_backend>
<slow_backend>database</slow_backend>
<fast_backend_options>
<servers>
<server>
<host>127.0.0.1</host>
<port>11211</port>
<persistent>1</persistent>
</server>
</servers>
</fast_backend_options>
<prefix><![CDATA[MAGE_]]></prefix>
</cache>

 

before i did that i backup my Local.xml file . When i got a error i uploaded the backup. But it gives me the same error. Please tell me how to fix this.

Image - Error

 

The file i got from error log record. Please tell me how to fix this problem.

 

NEW PROBLEM (EDITED) : Then, I deleted all the files in var/cache. Now, The first page of the website works fine but the product page aren't loading also the backend login page isn't loading. I don't understand what to do. Please help...

 


a:4:{i:0;s:65:"dbModel read resource does not implement Zend_Db_Adapter_Abstract";i:1;s:1637:"#0 /var/zpanel/hostdata/zadmin/public_html/elawonen_nl/includes/src/__default.php(32312): Varien_Data_Collection_Db->setConnection(false) #1 /var/zpanel/hostdata/zadmin/public_html/elawonen_nl/includes/src/__default.php(24213): Mage_Core_Model_Resource_Db_Collection_Abstract->__construct(Object(Mage_Core_Model_Resource_Website)) #2 /var/zpanel/hostdata/zadmin/public_html/elawonen_nl/includes/src/__default.php(24245): Mage_Core_Model_Config->getModelInstance('core_resource/w...', Object(Mage_Core_Model_Resource_Website)) #3 /var/zpanel/hostdata/zadmin/public_html/elawonen_nl/app/Mage.php(491): Mage_Core_Model_Config->getResourceModelInstance('core/website_co...', Object(Mage_Core_Model_Resource_Website)) #4 /var/zpanel/hostdata/zadmin/public_html/elawonen_nl/includes/src/__default.php(5882): Mage::getResourceModel('core/website_co...', Object(Mage_Core_Model_Resource_Website)) #5 /var/zpanel/hostdata/zadmin/public_html/elawonen_nl/includes/src/__default.php(5887): Mage_Core_Model_Abstract->getResourceCollection() #6 /var/zpanel/hostdata/zadmin/public_html/elawonen_nl/includes/src/__default.php(21091): Mage_Core_Model_Abstract->getCollection() #7 /var/zpanel/hostdata/zadmin/public_html/elawonen_nl/includes/src/__default.php(20949): Mage_Core_Model_App->_initStores() #8 /var/zpanel/hostdata/zadmin/public_html/elawonen_nl/includes/src/__default.php(20832): Mage_Core_Model_App->_initCurrentStore('', 'store') #9 /var/zpanel/hostdata/zadmin/public_html/elawonen_nl/app/Mage.php(684): Mage_Core_Model_App->run(Array) #10 /var/zpanel/hostdata/zadmin/public_html/elawonen_nl/index.php(87): Mage::run('', 'store') #11 {main}";s:3:"url";s:1:"/";s:11:"script_name";s:10:"/index.php";}

 

3 REPLIES

Re: "There has been an error processing your request" problem. Please help.

Go to includes directory and edit config.php file and comment below two lines.

 

define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');
define('COMPILER_COLLECT_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'stat');

 

Now clear your cache and check again.

 

Once your site start working, you need to again recompile your code from System=>Tools=>Compilation and enable compilation

Sr. Consultant
www.knowarth.com

Re: "There has been an error processing your request" problem. Please help.

I did comment the 2 lines but nothing happened. Same happen. Please help me out and elaborate the procedure. Please..

Re: "There has been an error processing your request" problem. Please help.

Please check the edited problem. Thank You.