cancel
Showing results for 
Search instead for 
Did you mean: 

No Theme Appearing on Multi Store Setup

No Theme Appearing on Multi Store Setup

I've setup a multi store in magento with a subdirectory  like the following

 

www.mydomain.com

www.mydomain.com/newstore

 

The themes are working fine on www.mydomain.com, however on www.mydomain.com/newstore it isn't appearing.

 

The website for www.mydomain.com/newstore seems to be working fine i.e. products descriptions are appearing (no images) and My Account is working.  It looks like the themes can't be found as no css or images are appearing.

 

I've setup the websites up with the themes in Admin --> System --> Design

 

The .htaccess file in the subdirectory has the following:

AuthType Basic
AuthName "Store Name"
AuthUserFile "/home1/mydomain/.htpasswds/public_html/mydomaincom/passwd"
require valid-user

SetEnvIf Host .*newstore.* MAGE_RUN_CODE='newstore'
SetEnvIf Host .*newstore.* MAGE_RUN_TYPE='website'

 

The bottom of my index.php in the subdirectory has the following:

 

$mageRunCode = 'newstore';
$mageRunType = 'website';

Mage::run($mageRunCode, $mageRunType);

 

Any ideas what could be causing this?

 

Thanks

3 REPLIES

Re: No Theme Appearing on Multi Store Setup

Just a thought Smiley Happy

I would check design under:

Admin > System > Configuration > Generel > Design > Packages / Design.

And remeber to chose store-view in upper left corner for each storeview.

 

-- Best regards --
Kent Christiansen / @KentChrDK / Magento Certified Solution Specialist / Visit my site (DK)

Re: No Theme Appearing on Multi Store Setup

Hmm - one thing that might be a clue is that you mentioned that product descriptions appear, but no images. Do you mean you have images attached to those products, and the product images aren't appearing either? 

 

Also, have you double checked the file ownership and permission settings of the subdirectory and any files under it? What do your base URL settings look like at the global and website levels in System -> Configuration? 

--Joshua Warren - @JoshuaSWarren on Twitter
CEO, Creatuity & Launchpad.
Magento Certified Developer, Front-end Developer, Solution Specialist

Re: No Theme Appearing on Multi Store Setup

What about files and folders structure on your webserver, how did you setup this ?

 

Have a look at this post from Stack - maybe it gives you some pointers on what I was referring to in my ealier post - did you try that ?

http://magento.stackexchange.com/questions/24367/how-to-setup-multi-stores-with-different-themes-for...

 

 

 

-- Best regards --
Kent Christiansen / @KentChrDK / Magento Certified Solution Specialist / Visit my site (DK)