cancel
Showing results for 
Search instead for 
Did you mean: 

Attempted to upgrade from 1.7 to 1.9 and now it says I have the wrong version of PHP.

Attempted to upgrade from 1.7 to 1.9 and now it says I have the wrong version of PHP.

Done in Magento Connect Manager.

 

Error message is:

"

Whoops, it looks like you have an invalid PHP version.

Magento supports PHP 5.3.0 or newer. Find out how to install Magento using PHP-CGI as a work-around.


"

 

Now that i've read through a little more, I see I broke the cardinal rule of not upgrading to 1.8 first. Whoops! Don't even know where I'd find it, anyway.

 

Thankfully, this is just a developer's test site AND I did tell it to create a backup first, though admittedly I have no idea where that backup is actually located or what I'd do with it. I did record a .txt file of the log that appeared while it installed 1.9 so I can share that if needed, but basically the dev site is broken. The admin page doesn't even load (any page that doesn't have the above error message is just blank white). Is it salvageable? 

Tags (2)
2 REPLIES

Re: Attempted to upgrade from 1.7 to 1.9 and now it says I have the wrong version of PHP.

Will you please specify which php version you are currently using in server and which steps you have followed to perform upgrade for your Magento from 1.7 to 1.9?

Re: Attempted to upgrade from 1.7 to 1.9 and now it says I have the wrong version of PHP.

I think latest Magento requires PHP 5.4+

Tanel Raja