cancel
Showing results for 
Search instead for 
Did you mean: 

Can't login admin page after upgraded from 1.9.0.1 to 1.9.1

SOLVED

Can't login admin page after upgraded from 1.9.0.1 to 1.9.1

Once I upgraded Magento form 1.9.0.1 to 1.9.1 on downloader, I cannot access the admin login page, it show blank. And I get error on page if I jump from downloader page to admin page

Here is the error

 

Fatal error: Call to a member function addLink() on a non-object in /opt/lampp/htdocs/magento/app/code/core/Mage/Adminhtml/Controller/Action.php on line 113

 

I look the code, the error is caused by $this->getLayout()->getBlock('breadcrumbs')->addLink($label, $title, $link);

I don't get it, where goes wrong.   Could anyone please point me right direction, or some debug steps for this? Thanks

12 REPLIES

Re: Can't login admin page after upgraded from 1.9.0.1 to 1.9.1

Hello,

 

To me it sounds like some files have been missed during the install of the upgrade. Please try the following.

 

  • download latest source from magento website
  • backup content of your app/design/adminhtml/default/default folder
  • replace the content of app/design/adminhtml/default/default with correspondent folder from magento website.
  • clean cache

Please let me know if this works.


Freelance Web Developer - Graphic Designer - SEO Analyst
Conor Rhys Tomkins

Re: Can't login admin page after upgraded from 1.9.0.1 to 1.9.1

Thank you very much Conor, I don't know why but there are some template files and css files missing.

Re: Can't login admin page after upgraded from 1.9.0.1 to 1.9.1

Glad to be of help.


Freelance Web Developer - Graphic Designer - SEO Analyst
Conor Rhys Tomkins

Re: Can't login admin page after upgraded from 1.9.0.1 to 1.9.1

Hello

 

i was trying to upgraded  my magento store and now i cannot login admin page after upgraded , i did make this steps but i count fix it please can someone help me with this

 

thanks you

Re: Can't login admin page after upgraded from 1.9.0.1 to 1.9.1

Connor, you missed what being reported back to you!

 

What happens when you replace the app/design/adminhtml/default/default content with the original, is that the css file is not being read anymore for the whole site.  While you can log into, the formatting is lost completely.

 

Here's what it looks like

 

no-ccs admin

I'm running into the same blank screen when I update to 1.9.2.0

Re: Can't login admin page after upgraded from 1.9.0.1 to 1.9.1

@lifeboy Are you having this issue just for your admin or frontend as well?


Freelance Web Developer - Graphic Designer - SEO Analyst
Conor Rhys Tomkins

Re: Can't login admin page after upgraded from 1.9.0.1 to 1.9.1

I am having same problem as lifeboy on admin side ..... front looks fine. Plus since upgrade it won't add items to cart.

Re: Can't login admin page after upgraded from 1.9.0.1 to 1.9.1

Sorry guys,

 

I've never come across this issue as of yet, so I don't know a fix.

 

Hopefully someone more knowledgeable than me will be along shortly.

 

Link me to your site, i'll see if I can quickly spot any issues on the frontend, but I dont have time to fully debug for you. Sorry.


Freelance Web Developer - Graphic Designer - SEO Analyst
Conor Rhys Tomkins

Re: Can't login admin page after upgraded from 1.9.0.1 to 1.9.1

For the missing styles in the admin panel you can try:

 

  • download latest source from magento website
  • backup content of your skin/adminhtml/default/default folder
  • replace the content of skin/adminhtml/default/default with correspondent folder from magento website.
  • clean cache

BUT PLEASE: Backup your store before doing any suggested changes!

 

It sounds like you are missing a CSS file, but without looking or knowing the issue, I can't guarantee anything.

 

You also may have some extension files in this folder, which will need to be replaced if the above does fix the admin issue.


Freelance Web Developer - Graphic Designer - SEO Analyst
Conor Rhys Tomkins