cancel
Showing results for 
Search instead for 
Did you mean: 

Do I need to install 1.9.2.2 over 1.9.2.1 or does adding SUPEE 6788 take me to 1.9.2.2

SOLVED

Do I need to install 1.9.2.2 over 1.9.2.1 or does adding SUPEE 6788 take me to 1.9.2.2

Sorry for the simplistic questions.  I noted that CE 1.9.2.2 was just released, as well as patch SUPEE 6788.

We installed CE 1.9.2.1 about 3 weeks ago for the first time, as a replacement for BigCommerce. 

My goal is to maintain our Magento server using the current "Best Business Practices" of the community. 

 

Q#1 Do I need to install CE 1.9.2.2 over CE 1.9.2.1 and if so, what if any benefits will this new release provide?

Q#2 Will the installation of CE 1.9.2.2 overwrite the "many" setting we have made to CE 1.9.2.1??

Q#3 Are all previous patches prior to SupEE 6788 included in CE 1.9.2.1?   Note!!!  70 plus admin alerts were present in 1.9.2.1 install going all  the way back several years.

Q#4 If I upgrade to CE 1.9.2.2, is SUP 6788 included in the build?

 

Thanks in advance. 

 

6 REPLIES

Re: Do I need to install 1.9.2.2 over 1.9.2.1 or does adding SUPEE 6788 take me to 1.9.2.2

 

you better upgrade to 1922, cause you just installed magento.

 

thank you

------------
MagenX - Magento and Server optimization

Re: Do I need to install 1.9.2.2 over 1.9.2.1 or does adding SUPEE 6788 take me to 1.9.2.2

Hello

Its better if you upgrade your magento version from 1.9.2.1 to 1.9.2.2 to protect against 10 security issues.

Thanks

Problem solved? Click Accept as Solution!
Magento Extension Developer | Facebook | Twitter

Re: Do I need to install 1.9.2.2 over 1.9.2.1 or does adding SUPEE 6788 take me to 1.9.2.2

Magento patches only fix known security issues or a limited set of features (shipping, image issues, credit card validation, etc.) needed to keep Magento running for the majority of users. Magento patches do not include the full version changes, bugfixes and feature changes and therefore do not count as a version upgrade and do not increment the version number.

 

In order to get all the changes in a version upgrade, you must apply the version upgrade (for example 1.9.2.1 needs the full 1.9.2.2 upgrade to increment the version upgrade and apply ALL the upgrade changes.

Re: Do I need to install 1.9.2.2 over 1.9.2.1 or does adding SUPEE 6788 take me to 1.9.2.2

Magento add good feature In 1.9.2.2.

after magento upgrade or install security patches you got error on system > permission

there is variables and blocks they added for restriction,

 

if you got error here regarding tables missing then dont worry, you can download permission_block and permission_variables tables default structure and data from here.

 

For more detail follow this article.

Magento Missing Blocks

Hope it will help full to some one else.

Ubed Arab

Re: Do I need to install 1.9.2.2 over 1.9.2.1 or does adding SUPEE 6788 take me to 1.9.2.2

Thank you Ubed, the missing table dump you posted worked for me.

Re: Do I need to install 1.9.2.2 over 1.9.2.1 or does adding SUPEE 6788 take me to 1.9.2.2

So here is what I do and it seems to work for me (so far). I didn't come up with this myself. I just spent hours of researching and digging and I finally came up with something that works for me.

 

Important:
1. Always create an exact duplicate of web directory:
cp -rp html html_backup (html being the directory Magento is in)
2. Always create a copy of the current database using phpMyAdmin, command line tool or similar

 

Set Site into maintenance mode:
touch maintenance.flag

 

Go inside your Magento folder (in this case 'html') and change permissions RECURSIVELY to "777”:
chmod -R 777 *

Then the upgrade part:

run ./mage mage-setup

If there is an error like:
channel-add: Unknown cipher in list: TLSv1
then you need to make an edit here:

downloader/lib/Mage/HTTP/Client/Curl.php, try changing:
$this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1');
to
$this->curlOption(CURLOPT_SSLVERSION, CURL_SSLVERSION_TLSv1);
then
rerun ./mage mage-setup
If you get another error like:

channel-add: Channel ‘community’ already exist!
then we should still be good to proceed.

 

./mage config-set preferred_state stable

./mage sync

 

Then to upgrade:

./mage list-upgrades
./mage upgrade-all —force

 

More info here:
https://www.yireo.com/blog/1294-magento-15-mage-command-line
and more here:
https://www.skyverge.com/blog/how-to-upgrade-magento/

 

Then some maintenance:

php shell/indexer.php reindexall
rm -rf downloader/.cache/ var/cache/

 

Then I set my permissions like so (because the new permissions that Magento recommends I find plain silly):

find . -type f -exec chmod 644 '{}' \;
find . -type d -exec chmod 755 '{}' \;
chmod -R o+w media
chmod 777 -R var media
chmod 550 mage

 

Disable Maintenance Mode:
rm maintenance.flag

 

If you are using opcache then be sure to reset the opcache several times.

 

Now go your home page, and then log in at your admin page. You should now see that you are upgraded to the latest version Magento (that is.. if you are using 1.9.2.x you will have the latest version of 1.9.2.x of course. It will not upgrade to Magento 2 this way).

 

Hope that this is helpful to some of you. It has always worked for me. I don't have any core mods I might add, and if you have modded one of your default themes then make sure that you have a backup because you will have to manually go back in and modify whatever you need.

 

Thanks.