Showing results for 
Search instead for 
Did you mean: 

Installing Inchoo Patch


Installing Inchoo Patch

Is installing the inchoo patch as simple as downloading the latest app/code and app/etc files and ftp them up to my server?  Well that is what I did and then i switched my php version to 7 and logged in but I don't know how to tell if it is running on 7 now and if it all "worked"  when i run php inchoo_php7_test.php  I dont get anything at all as a result, the command line just comes back to the prompt.


Re: Installing Inchoo Patch

Hi @tagteamc,


Normally yes, just install the module and that's all.

Of course, maybe some custom module or third-part module can have some errors, but that is a different story.

Can you check this command on your server's console?


php -v

Can you share the output?

If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Installing Inchoo Patch

Hey Damian,

php -v shows as PHP 7.0.28  but when running the command I am logged in to the shell as root after using sudo from a log in user, not the account in question.


In cpanel multiphp editor for the domain it does show PHP Version ea-php70 as well.


My big concern was the "install module" i am a system admin and I am used to "ftp'ing files to the server"  Which appears to be the same as "install module" in this case.

Re: Installing Inchoo Patch

Hey there, using FTP is the same as installing using other mechanisms. You can go to app/etc/modules/Inchoo_PHP7.xml and ensure the line below is set to true.


You can also create a file phpinfo.php with the contents below, then hit it in your web browser to ensure PHP is using version 7.

<?php phpinfo(); ?>

Re: Installing Inchoo Patch

I enabled php_info on my server and tested and it does show php 7 and I checked the file and it is true. 


Thanks for the help.  Since i am an admin I think of installing a module as some sort of package that you upload and install like a wordpress theme or plugin.  So the use of  the term "install a module" that is really just ftp'ing files to the server was just a bit confusing to me.


Thanks for the confirmation, looks like my inchoo patch is installed and running correctly.