cancel
Showing results for 
Search instead for 
Did you mean: 

Is 1.9.2.3 compatible with PHP 5.6?

Is 1.9.2.3 compatible with PHP 5.6?

 

 My host provider wants to make this switch.. previously I was running 5.3.29 which had some issues with the 1.9.01 to 1.9.2.3 jump. 

 

Before he does the update I'd like an idea of the headaches I'm likely to encounter and any helpful links to solutions would be greatly appreciated.

 

Thanks,

Eric

Tags (1)
3 REPLIES

Re: Is 1.9.2.3 compatible with PHP 5.6?

Officially, since1.9.1.0, excerpt for their release

 

 > Magento Community Edition 1.9.1 works with MySQL 5.6 and PHP 5.5

 

There are a few incompatibilities in 1.9 when running with PHP 5.6, specifically in the Zend library. The following link discusses what is necessary to overcome this.


http://magento.stackexchange.com/questions/34015/magento-1-9-php-5-6-use-of-iconv-internal-encoding-...

Re: Is 1.9.2.3 compatible with PHP 5.6?

 

 Thank you for the reply Chief..  I did look at that issue you listed and I checked the code in the 1.9.2.3 release and I think they've addressed this..  They now do a PHP version check in the code for Hostname.php

 

OLD:

       $origenc = iconv_get_encoding('internal_encoding');
            iconv_set_encoding('internal_encoding', 'UTF-8');

1.9.2.3

 

      $origenc = PHP_VERSION_ID < 50600
                        ? iconv_get_encoding('internal_encoding')
                        : ini_get('default_charset');
            if (PHP_VERSION_ID < 50600) {
                iconv_set_encoding('internal_encoding', 'UTF-8');
            } else {
                ini_set('default_charset', 'UTF-8');
            }

Eric

Re: Is 1.9.2.3 compatible with PHP 5.6?

Sweet! Thanks for the information. I'm facing the same issue once I get past the upgrade and can run higher than PHP 5.4.