cancel
Showing results for 
Search instead for 
Did you mean: 

Is CE 1.9.3.7 or 1.9.3.8 compatible with MySQL 5.7?

Is CE 1.9.3.7 or 1.9.3.8 compatible with MySQL 5.7?

I want to move our system to a new server which would run on MySQL 5.7 (but has HTTP/2). I have checked several threads and posts and I am not quite sure what to make of a final result.

 

Some claim it worked, others say it's strictly 5.6 (as stated in the official system requirements). I am always running on the latest 1.9.X.X versions and my webhost says risks are minimal.

 

Does anybody have some valid proof that this works? Is there an official statement from Magento which is newer than regarding CE 1.9.0?

Tags (1)
2 REPLIES

Re: Is CE 1.9.3.7 or 1.9.3.8 compatible with MySQL 5.7?

Hi @TheFrakes,

 

Which documentation or references about issues did you found?

 

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Is CE 1.9.3.7 or 1.9.3.8 compatible with MySQL 5.7?

Hi Damian,

 

I have found the following discussions with no clear answers but with concerns and possible errors or warnings:

- https://community.magento.com/t5/Version-Upgrades/Is-CE1-9-0-1-compatible-with-MySQL-5-7/td-p/43681

- https://magento.stackexchange.com/questions/130828/is-ce-1-9-0-1-compatible-with-mysql-5-7

 

A problem with url_rewirtes that can be fixed after upgrading to 5.7:

- https://github.com/hvanmegen/magento-mysql-5.7-join-fix

- https://github.com/OpenMage/magento-lts/issues/295

 

The official Magento 1 system requirements say only 5.6 is fully supported:

- http://devdocs.magento.com/guides/m1x/system-requirements.html

 

These are the sources I have found so far...