cancel
Showing results for 
Search instead for 
Did you mean: 

Is CE1.9.0.1 compatible with MySQL 5.7?

Is CE1.9.0.1 compatible with MySQL 5.7?

Hello!

 

My webhost is currently planning to upgrade all servers from MySQL 5.6 to 5.7 within the next two weeks. I have done a little digging and have not found any real clarification if CE1.9.0.1 runs on 5.7 or not. So I was wondering, can anyone clarify this or if there may be some action I'll need to take? Thanks!

3 REPLIES

Re: Is CE1.9.0.1 compatible with MySQL 5.7?

Hi @WinteRx182

 

As per Magento official system requirement documentation MySQL 5.6 is supported Magento 1x System Requirement

 

If we see the Magento 2  system  requirement documentation there also MySQL 5.6 is mentioned.Magento 2x System Requirement

 

If you visit following link http://devdocs.magento.com/guides/v2.1/install-gde/prereq/mysql.html   , there is e a section as  following (Though it is for Magento 2)

 

Magento does not support MySQL 5.7 at this time.

These instructions are provided for your convenience if you'd like to test MySQL 5.7

 

I suggest you try 5.7 on stage environment to see if it breaks any code flow. 

 

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: Is CE1.9.0.1 compatible with MySQL 5.7?

I would first question your hosting provider for forcing you to upgrade. I can already tell it isn't a Magento host.

 

I would recommend having them setup a staging server for you to test. Otherwise, essentially they are telling you "Hey, we are going to upgrade your systems. I hope nothing breaks for you".

 

Here are some release notes: https://dev.mysql.com/doc/refman/5.7/en/upgrading-from-previous-series.html

 

 

-Kris
4x Certified, Blogger @ xgento.com

Re: Is CE1.9.0.1 compatible with MySQL 5.7?

As I know, Magento CE 1.9 is compatible with MySQL 5.7 However, you should be careful in upgrading. You receive some warning notifications. It is not problem.